<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
	<title>Malaysia Chronicle</title>
	<meta name='robots' content='max-image-preview:large' />
<!-- Grow Social by Mediavine v.1.20.1 https://marketplace.mediavine.com/grow-social-pro/ -->
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#039;CASH IS KING&#039; ZAFRUL NOT WELCOME EVEN BY UMNO GRASSROOTS IN KUALA SELANGOR - &#039;WE HAVE BEEN WORKING HARD SINCE 2018, AND NOW HE COMES HERE AFTER WE HAVE DONE ALL THE WORK&#039;" />
<meta property="og:description" content="Focus on your job, not Kuala Selangor, Tengku Zafrul told FINANCE minister Tengku Zafrul Tengku Abdul Aziz should focus on his job and the economy and not try to woo voters in Kuala Selangor, said" />
<meta property="og:url" content="https://www.malaysia-chronicle.com/?p=217458" />
<meta property="og:site_name" content="Malaysia Chronicle" />
<meta property="og:updated_time" content="2022-06-07T18:50:07+00:00" />
<meta property="article:published_time" content="2022-06-07T18:50:07+00:00" />
<meta property="article:modified_time" content="2022-06-07T18:50:07+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="&#039;CASH IS KING&#039; ZAFRUL NOT WELCOME EVEN BY UMNO GRASSROOTS IN KUALA SELANGOR - &#039;WE HAVE BEEN WORKING HARD SINCE 2018, AND NOW HE COMES HERE AFTER WE HAVE DONE ALL THE WORK&#039;" />
<meta name="twitter:description" content="Focus on your job, not Kuala Selangor, Tengku Zafrul told FINANCE minister Tengku Zafrul Tengku Abdul Aziz should focus on his job and the economy and not try to woo voters in Kuala Selangor, said" />
<meta property="og:image" content="https://www.malaysia-chronicle.com/wp-content/uploads/2022/06/1258293-8.jpg" />
<meta name="twitter:image" content="https://www.malaysia-chronicle.com/wp-content/uploads/2022/06/1258293-8.jpg" />
<meta property="og:image:width" content="620" />
<meta property="og:image:height" content="324" />
<!-- Grow Social by Mediavine v.1.20.1 https://marketplace.mediavine.com/grow-social-pro/ -->
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans">
<link rel="stylesheet" href="https://www.malaysia-chronicle.com/wp-content/themes/mnews/style.css" media="screen">
<link rel="pingback" href="https://www.malaysia-chronicle.com/xmlrpc.php"/>
<link rel="shortcut icon" href="https://www.malaysia-chronicle.com/wp-content/themes/mnews/images/favicon.ico" type="image/x-icon" />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//cdn.innity.net' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; Feed" href="https://www.malaysia-chronicle.com/?feed=rss2" />
<link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; Comments Feed" href="https://www.malaysia-chronicle.com/?feed=comments-rss2" />
<link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; &#8216;CASH IS KING&#8217; ZAFRUL NOT WELCOME EVEN BY UMNO GRASSROOTS IN KUALA SELANGOR &#8211; &#8216;WE HAVE BEEN WORKING HARD SINCE 2018, AND NOW HE COMES HERE AFTER WE HAVE DONE ALL THE WORK&#8217; Comments Feed" href="https://www.malaysia-chronicle.com/?feed=rss2&#038;p=217458" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.malaysia-chronicle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.malaysia-chronicle.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='dpsp-frontend-style-pro-css'  href='https://www.malaysia-chronicle.com/wp-content/plugins/social-pug/assets/dist/style-frontend-pro.1.20.1.css?ver=1.20.1' type='text/css' media='all' />
<link rel='stylesheet' id='popular-widget-css'  href='https://www.malaysia-chronicle.com/wp-content/plugins/popular-widget/_css/pop-widget.css?ver=1.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='myStyleSheets-css'  href='https://www.malaysia-chronicle.com/wp-content/plugins/wp-latest-posts/css/wplp_front.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='myFonts-css'  href='https://fonts.googleapis.com/css?family=Raleway%3A400%2C500%2C600%2C700%2C800%2C900%7CAlegreya%3A400%2C400italic%2C700%2C700italic%2C900%2C900italic%7CVarela+Round&#038;subset=latin%2Clatin-ext&#038;ver=6.0' type='text/css' media='all' />
<script type='text/javascript' src="https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js?ver=6.0" id='jquery-js'></script>
<script type='text/javascript' src="https://code.jquery.com/jquery-migrate-1.2.1.min.js?ver=6.0" id='jquery migrate-js'></script>
<script type='text/javascript' src='https://www.malaysia-chronicle.com/wp-content/themes/mnews/js/scripts.js?ver=6.0' id='scripts-js'></script>
<script type='text/javascript' src='https://www.malaysia-chronicle.com/wp-content/themes/mnews/js/jquery-news-ticker.js?ver=6.0' id='news-ticker-js'></script>
<script type='text/javascript' src="https://cdn.innity.net/admanager.js?ver=6.0" id='inniti-universal-js'></script>
<link rel="https://api.w.org/" href="https://www.malaysia-chronicle.com/index.php?rest_route=/" /><link rel="alternate" type="application/json" href="https://www.malaysia-chronicle.com/index.php?rest_route=/wp/v2/posts/217458" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.malaysia-chronicle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.malaysia-chronicle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0" />
<link rel="canonical" href="https://www.malaysia-chronicle.com/?p=217458" />
<link rel='shortlink' href='https://www.malaysia-chronicle.com/?p=217458' />
<link rel="alternate" type="application/json+oembed" href="https://www.malaysia-chronicle.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D217458" />
<link rel="alternate" type="text/xml+oembed" href="https://www.malaysia-chronicle.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D217458&#038;format=xml" />
	<div id="fb-root"></div>
	<script>(function(d, s, id) {
	  var js, fjs = d.getElementsByTagName(s)[0];
	  if (d.getElementById(id)) return;
	  js = d.createElement(s); js.id = id;
	  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=&version=v2.3";
	  fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));</script><style type="text/css" data-source="Grow Social by Mediavine">
				@media screen and ( max-width : 720px ) {
					.dpsp-content-wrapper.dpsp-hide-on-mobile,
					.dpsp-share-text.dpsp-hide-on-mobile,
					.dpsp-content-wrapper .dpsp-network-label {
						display: none;
					}
					.dpsp-has-spacing .dpsp-networks-btns-wrapper li {
						margin:0 2% 10px 0;
					}
					.dpsp-network-btn.dpsp-has-label:not(.dpsp-has-count) {
						max-height: 40px;
						padding: 0;
						justify-content: center;
					}
					.dpsp-content-wrapper.dpsp-size-small .dpsp-network-btn.dpsp-has-label:not(.dpsp-has-count){
						max-height: 32px;
					}
					.dpsp-content-wrapper.dpsp-size-large .dpsp-network-btn.dpsp-has-label:not(.dpsp-has-count){
						max-height: 46px;
					}
				}
			</style><style data-context="foundation-flickity-css">/*! Flickity v2.0.2
http://flickity.metafizzy.co
---------------------------------------------- */.flickity-enabled{position:relative}.flickity-enabled:focus{outline:0}.flickity-viewport{overflow:hidden;position:relative;height:100%}.flickity-slider{position:absolute;width:100%;height:100%}.flickity-enabled.is-draggable{-webkit-tap-highlight-color:transparent;tap-highlight-color:transparent;-webkit-user-select:none;-moz-user-select:none;-ms-user-select:none;user-select:none}.flickity-enabled.is-draggable .flickity-viewport{cursor:move;cursor:-webkit-grab;cursor:grab}.flickity-enabled.is-draggable .flickity-viewport.is-pointer-down{cursor:-webkit-grabbing;cursor:grabbing}.flickity-prev-next-button{position:absolute;top:50%;width:44px;height:44px;border:none;border-radius:50%;background:#fff;background:hsla(0,0%,100%,.75);cursor:pointer;-webkit-transform:translateY(-50%);transform:translateY(-50%)}.flickity-prev-next-button:hover{background:#fff}.flickity-prev-next-button:focus{outline:0;box-shadow:0 0 0 5px #09f}.flickity-prev-next-button:active{opacity:.6}.flickity-prev-next-button.previous{left:10px}.flickity-prev-next-button.next{right:10px}.flickity-rtl .flickity-prev-next-button.previous{left:auto;right:10px}.flickity-rtl .flickity-prev-next-button.next{right:auto;left:10px}.flickity-prev-next-button:disabled{opacity:.3;cursor:auto}.flickity-prev-next-button svg{position:absolute;left:20%;top:20%;width:60%;height:60%}.flickity-prev-next-button .arrow{fill:#333}.flickity-page-dots{position:absolute;width:100%;bottom:-25px;padding:0;margin:0;list-style:none;text-align:center;line-height:1}.flickity-rtl .flickity-page-dots{direction:rtl}.flickity-page-dots .dot{display:inline-block;width:10px;height:10px;margin:0 8px;background:#333;border-radius:50%;opacity:.25;cursor:pointer}.flickity-page-dots .dot.is-selected{opacity:1}</style><link rel="icon" href="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-270x270.jpg" />
<style>.ios7.web-app-mode.has-fixed header{ background-color: rgba(238,238,34,.88);}</style><style>
.ai-viewports                 {--ai: 1;}
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
	
	<!-- Place this code ONLY ONCE into the HEAD element of the web page -->
<script type="text/javascript" src="https://cdn.innity.net/admanager.js"></script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	

</head>
	
	<body class="post-template-default single single-post postid-217458 single-format-standard"> 
	<div class="container">
		<header class="header-wrap">
			<div class="wrapper">
				<div class="logo-wrap" role="banner">
				<div class="logo">
<a href="https://www.malaysia-chronicle.com/" title="Malaysia Chronicle" rel="home">
</a>
</div>
					

					
									<div class="ad-topline">
						<div class="sp-widget"> <!-- Zone Tag : malaysiachronicle123 DESKTOP LEADERBOARD -->
<script type="text/javascript">
new innity_adZone("e077e1a544eec4f0307cf5c3c721d944", "94643", {"origin": "MY", "width": "728", "height": "90"});
</script> </div>					</div>
								</div>
			</div>
			<nav class="main-nav clearfix">	
				<div class="wrapper">
					<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-194847" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-194847"><a href="https://www.malaysia-chronicle.com/">Homepage</a></li>
<li id="menu-item-118482" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-118482"><a href="https://www.malaysia-chronicle.com/?cat=2">Politics</a></li>
<li id="menu-item-121976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121976"><a href="https://www.malaysia-chronicle.com/?cat=27">Malay</a></li>
<li id="menu-item-118484" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118484"><a href="https://www.malaysia-chronicle.com/?cat=3">Business</a></li>
<li id="menu-item-118485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118485"><a href="https://www.malaysia-chronicle.com/?cat=4">Social</a></li>
<li id="menu-item-118486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118486"><a href="https://www.malaysia-chronicle.com/?cat=7">Videos</a></li>
<li id="menu-item-120318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120318"><a href="https://www.malaysia-chronicle.com/?cat=6">Latest</a></li>
</ul></div>						<div class="search-box">
		<form role="search" method="get" id="searchform" action="">
			<fieldset>
				<input name="s" id="s" value="" autocomplete="off" placeholder="SEARCH" type="text">
				<input id="searchsubmit" value="" type="submit">
			</fieldset>
		</form>
	</div>				</div>
			</nav>
						


			
			
			
			
			

  <!-- Place this code where this unit should show in the page body -->
<!-- Zone Tag : malaysiachronicle123 Universal Tag_EN -->
<script type="text/javascript">
new innity_adZone("e077e1a544eec4f0307cf5c3c721d944", "41786", {"origin": "MY"});
</script> 			


</header>
	
							<div class="wrapper ad-leader1">
			<div class="sp-widget"><style>#M100146ScriptRootC1017239 {min-height: 300px;}</style>
<!-- Composite Start -->
<div id="M100146ScriptRootC1017239">
</div>
<script src="https://jsc.mgid.com/m/a/malaysia-chronicle.com.1017239.js" async></script>
<!-- Composite End --></div>			</div>
		
		
	 		
		
		<div class="wrapper clearfix">
	<div class="content left"><article class="post-217458 post type-post status-publish format-standard has-post-thumbnail hentry category-politics grow-content-body">
	<header class="post-header">			
		<h1 class="entry-title">&#8216;CASH IS KING&#8217; ZAFRUL NOT WELCOME EVEN BY UMNO GRASSROOTS IN KUALA SELANGOR &#8211; &#8216;WE HAVE BEEN WORKING HARD SINCE 2018, AND NOW HE COMES HERE AFTER WE HAVE DONE ALL THE WORK&#8217;</h1>
				<p class="meta post-meta">
			<a href="https://www.malaysia-chronicle.com/?cat=2" rel="category">Politics</a>  |  
			<span class="updated">June 7, 2022 6:50 pm</span> by 			<span class="vcard author">
							</span>  |  0 Comments</p>
	</header>
		<div class="entry clearfix">
		
<div class="post-thumbnail">
<a href="https://www.malaysia-chronicle.com/wp-content/uploads/2022/06/1258293-8.jpg" rel="prettyPhoto"><img src="https://www.malaysia-chronicle.com/wp-content/uploads/2022/06/1258293-8.jpg" alt="" title="1258293" /></a>
</div>
		<p>Focus on your job, not Kuala Selangor, Tengku Zafrul told</p>
<div class="news-ads">
<div id="article-primary-leaderboard" data-google-query-id="CPidq7iMm_gCFauQZgIdiG8PeA">
<div id="google_ads_iframe_/1582411174/up_lb_section_0__container__">FINANCE minister Tengku Zafrul Tengku Abdul Aziz should focus on his job and the economy and not try to woo voters in Kuala Selangor, said Umno vice-president Khaled Nordin.</div>
</div>
</div>
<article class="news-body" data-kiosked-context-name="kskdUIContext_01g4yt7ahzrmz1amvhz51ffrrf">He also said the Treasury does not need to “adopt” any parliamentary constituency.</p><div class='code-block code-block-4' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- Composite Start -->
<div id="M100146ScriptRootC1017224">
</div>
<script src="https://jsc.mgid.com/m/a/malaysia-chronicle.com.1017224.js" async></script>
<!-- Composite End --></div>

<p>His comments come after Tengku Zafrul over the weekend announced that he will be “adopting” the district.</p>
<p>Khaled said Putrajaya should instead address issues like the surging food and commodity prices, recurring traffic congestions and LRT delays.</p>
<div class="news-ads m-reg">
<div id="article-mreg" data-google-query-id="CPmdq7iMm_gCFauQZgIdiG8PeA">
<div id="google_ads_iframe_/1582411174/stories_mrec_0__container__">He added that passports take weeks to be renewed and thousands wait in long lines at the Johor-Singapore Causeway.</div>
</div>
</div>
<p><span style="color: #ff0000;"><strong>“Barisan Nasional is also responsible for all of this as it is part of the government. The prime minister is facing attacks due to negligence by ministers in carrying out their responsibilities,” he wrote on Facebook today.</strong></span></p>
<p><span style="color: #ff0000;"><strong>“It is unfair to blame the prime minister when ministers should step up to the plate and show leadership.</strong></span></p>
<p><span style="color: #ff0000;"><strong>“However, for the finance minister, his priority appears to be Kuala Selangor.”</strong></span></p>
<p><span style="color: #800080;"><strong>Tengku Zafrul is allegedly eyeing the Kuala Selangor parliamentary seat and has attended several high profile activities in the district.</strong></span></p>
<p><span style="color: #800080;"><strong>He created a stir on Saturday, when he said he will be “adopting” the district.</strong></span></p>
<p><span style="color: #800080;"><strong>The senator hosted the Majlis Kenduri Rakyat in Puncak Alam yesterday, where he said his ministry is “adopting” Kuala Selangor and help spur its development.</strong></span></p>
<p>“Personally, I am a little sentimental about the Kuala Selangor district,” he told the audience, as quoted by Bernama.</p>
<p>“There are many local potentials that can be developed and highlighted.”</p><div class='code-block code-block-7' style='margin: 8px 0; clear: both;'>
<!-- Composite Start -->
<div id="M100146ScriptRootC1018821">
</div>
<script src="https://jsc.mgid.com/m/a/malaysia-chronicle.com.1018821.js" async></script>
<!-- Composite End --></div>

<p>His announcement also received flak from DAP secretary-general Anthony Loke, who said the “adoption” is an <a href="https://www.themalaysianinsight.com/s/385103">abuse of authority</a>.</p>
<p><span style="color: #ff0000;"><strong>“I have been an MP since 2008 and never heard of any federal ministry ‘adopting’ a district.</strong></span></p>
<p><span style="color: #ff0000;"><strong>“A ministry should be making policies and delivering services nationwide, not just for a locality.”</strong></span></p>
<p><span style="color: #ff00ff;"><strong>Tengku Zafrul has also <a style="color: #ff00ff;" href="https://www.themalaysianinsight.com/s/384757">irked local Umno leaders</a> with his activities in the district.</strong></span></p>
<p>Kuala Selangor Umno chief Jahaya Ibrahim said these activities are “disruptive” to the grassroots machinery there.</p>
<p>The finance minister is taking advantage of Umno’s restored popularity to stake a claim for the seat, he added.</p>
<p><span style="color: #ff0000;"><strong>“We have been working hard since 2018, and now he comes here after we have done all the work,” he told The Malaysian Insight.</strong></span></p>
<p>The Kuala Selangor seat is held by Amanah’s Dr Dzulkefly Ahmad.</p>
<p>The ex-health minister first won the seat under PAS in 2008, but lost it to Barisan Nasional in 2013.</p>
<p>He reclaimed the seat in 2018, defeating Umno’s Irmohizam Ibrahim and PAS’ Mohd Fakaruddin Ismail with a 8,498-vote majority.  TMI</p>
<div class="row">
<div class="small-12 columns">
<h2 class="main-title">Tengku Zafrul’s presence in Kuala Selangor upsets local Umno leaders</h2>
</div>
</div>
<article class="news-body" data-kiosked-context-name="kskdUIContext_01g4ytb05n390gsbfg9qwk70hg">
<p class="7315_2404:160:802b:3e4f:e834:93df:1f12:76c1">FINANCE Minister Tengku Zafrul Abdul Aziz’s presence in Kuala Selangor amid talk that he is eyeing the seat has made certain local Umno leaders unhappy.</p>
<p>Zafrul and his team have launched a publicity campaign in the area with activities promoting the senator without going through the local Umno leadership, which is “disruptive” to the grassroots machinery there, said Umno division chief Jahaya Ibrahim.</p>
<p>He told The Malaysian Insight that Tengku Zafrul was taking advantage of Umno’s restored popularity to stake a claim to the seat.</p>
<p><span style="color: #ff0000;"><strong>“We have been working hard since 2018 and now he wants to come here after we’ve done all the work,” said Jahaya.</strong></span></p>
<div class="news-ads m-reg">
<div id="article-mreg" data-google-query-id="CNnLrvSMm_gCFUGIZgIdGbYGDQ">
<div id="google_ads_iframe_/1582411174/stories_mrec_0__container__"><span style="color: #ff0000;"><strong>“He tried to come here but the Kuala Selangor Umno division rejected him. But despite our rejection, he persists in encroaching on our territory.”</strong></span></div>
</div>
</div>
<p>Jahaya said this is upsetting the local machinery which is preparing for the general election, which expected to be called soon.</p>
<p>Although Tengku Zafrul has not commented on the issue, the senator is rumoured to be interested in contesting in GE15. Media have speculated on a few seats, including Kuala Selangor where he has been holding programmes recently.</p>
<p>Umno higher-ups have not commented on the possibility of Tengku Zafrul becoming a party candidate.</p>
<p><span style="color: #ff0000;"><strong>Umno secretary-general Ahmad Maslan confirmed that the former banker is a long-time Umno member, a fact that is not widely known.</strong></span> Zafrul was appointed finance minister by Bersatu’s Muhyiddin Yassin is seen as a Muhyiddin ally. He kept his portfolio under the Ismail Sabri Yaakob administration.</p>
<p><span style="color: #ff0000;"><strong>According to Jahaya, Selangor Umno leaders have been informed about Tengku Zafrul’s presence.</strong></span></p>
<p><span style="color: #ff0000;"><strong>“I have told Selangor chief Noh Omar that I’m against his intrusion.”</strong></span></p>
<p><span style="color: #ff0000;"><strong>Jahaya said he has also sent letters to all the Umno branches in Kuala Selangor not to take part in Tengku Zafrul’s events.</strong></span></p>
<p><span style="color: #ff0000;"><strong>“I will raise the matter to the Umno disciplinary board if Tengku Zafrul continues to intrude into our area,” he added.</strong></span></p>
<p>However, while Jahaya is clearly against Tengku Zafrul’s “interest” in the Kuala Selangor seat, Noh has dismissed the “intrusion”.</p>
<p><span style="color: #ff0000;"><strong>In a statement on May 18, Noh said that it was acceptable for Tengku Zafrul to be seen in Kuala Selangor as the state needed “minister-level” leaders in the state ahead of GE15.</strong></span></p>
<p>The division’s Umno Youth deputy chief Amin Shukor also questioned Tengku Zafrul’s motives.</p>
<p>“I am not questioning his qualifications. But why is he only showing up in Kuala Selangor when Umno has 22 divisions in the state.</p>
<p>“If he is genuine about helping Selangor, he should go to all the divisions and not just Kuala Selangor. Would he be here if Umno is weak?” said Amin.</p>
<p>Currently the Kuala Selangor seat is held by former health minister and Amanah leader Dr Dzulkefly Ahmad.</p>
<p>The Amanah strategist first won the Kuala Selangor seat in 2008 under PAS before losing it to Barisan Nasional in 2013. In 2018, Dzulkefly won the seat again after defeating Umno’s Irmohizam Ibrahim and PAS’ Mohd Fakaruddin Ismail by 8,498 votes. TMI</p>
<div class="td-post-header">
<header class="td-post-title">
<h1 class="entry-title">Tengku Zafrul’s ‘cash is king’ culture won’t work, says Dzulkefly<img style="font-size: 16px;" src="https://platform-cdn.sharethis.com/img/email.svg" alt="email sharing button" /></h1>
</header>
</div>
<div class="td-post-content tagdiv-type">
<figure id="attachment_2058791" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-2058791" src="https://s3media.freemalaysiatoday.com/wp-content/uploads/2022/06/Dzulkefly-Ahmad-tengku-Zafrul.jpg" sizes="(max-width: 800px) 100vw, 800px" srcset="https://s3media.freemalaysiatoday.com/wp-content/uploads/2022/06/Dzulkefly-Ahmad-tengku-Zafrul.jpg 800w, https://s3media.freemalaysiatoday.com/wp-content/uploads/2022/06/Dzulkefly-Ahmad-tengku-Zafrul-300x188.jpg 300w, https://s3media.freemalaysiatoday.com/wp-content/uploads/2022/06/Dzulkefly-Ahmad-tengku-Zafrul-768x480.jpg 768w, https://s3media.freemalaysiatoday.com/wp-content/uploads/2022/06/Dzulkefly-Ahmad-tengku-Zafrul-696x435.jpg 696w, https://s3media.freemalaysiatoday.com/wp-content/uploads/2022/06/Dzulkefly-Ahmad-tengku-Zafrul-672x420.jpg 672w" alt="" width="800" height="500" data-kiosked-context-name="kskdUIContext_01g4yt7cf6r2590m6f7fb3frk5" /><figcaption class="wp-caption-text">Dzulkefly Ahmad (left) says Tengku Zafrul Aziz ‘appears to be a desperado’ in his attempt to win over the hearts of the Kuala Selangor voters.</figcaption></figure>
<p>PETALING JAYA: Luring Kuala Selangor voters with goodies will not sway them, their MP, Dzulkefly Ahmad, said following mega projects and other “goodies” promised by finance minister Tengku Zafrul Aziz there.</p>
<p>He said that while he wanted his constituents to benefit from development and prosperity, Tengku Zafrul’s apparent adoption of a “cash is king” culture was worrying.</p>
<div id="div-gpt-ad-1608712148585-0" data-google-query-id="CNTW47WMm_gCFRSGZgIdqDQMsA">
<div id="google_ads_iframe_/1009103/FMT_In_Article_Midrec_0__container__">“I’m confident the Kuala Selangor people will not be easily taken in by what appears to be <span style="color: #ff0000;"><strong>political bribery to win support.</strong></span></div>
</div>
<p data-kiosked-context-name="kskdUIContext_01g4yt7ch66dd8zrb7tdczyg3v"><span style="color: #ff0000;"><strong>“It is also very worrying that he (Tengku Zafrul) seems inclined towards a ‘cash is king’ culture. It is a moral hazard in a country that aspires to eradicate power abuse and corruption,” the Amanah leader said in a statement today.</strong></span></p>
<p>Dzulkefly also said Tengku Zafrul ought to fulfil his promise of setting up an Urban Transformation Centre (UTC) at Lembah Pantai.</p>
<p>“He made this promise when he appeared to be eyeing the parliamentary seat there in 2020,” he said.</p>
<p>He said the promise of a new East Coast Rail Link station at Puncak Alam, and the finance ministry’s adoption of Kuala Selangor were unprecedented in 60 years of the Alliance and Barisan Nasional governments.</p>
<p><span style="color: #ff0000;"><strong>“The minister appears to be a desperado. He should fulfil earlier promises rather than spread sweet, new promises,” he said.</strong></span></p>
<p>There has been speculation that Tengku Zafrul will contest for the Kuala Selangor parliamentary seat in GE15 on an Umno ticket. He is said to be an Umno member in the Lembah Pantai Umno division, according to a news report.</p>
<p data-kiosked-context-name="kskdUIContext_01g4yt7ch66dd8zrb7tdczyg3v">He recently announced the “adoption” of Kuala Selangor under his ministry and said an East Coast Rail Link station was slated to be built at Puncak Alam.</p>
<p>Observers had described this as a “clear indicator” that he will contest for the parliamentary seat.</p>
<p>FMT has contacted Tengku Zafrul for comment.   FMT</p>
<p>THE MALAYSIAN INSIGHT / FREE MALAYSIA TODAY</p>
<p>.</p><div class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<!-- Composite Start -->
<div id="M100146ScriptRootC1018808">
</div>
<script src="https://jsc.mgid.com/m/a/malaysia-chronicle.com.1018808.js" async></script>
<!-- Composite End -->

<!-- Composite Start -->
<div id="M100146ScriptRootC43439">
</div>
<script src="https://jsc.mgid.com/m/a/malaysia-chronicle.com.43439.js" async></script>
<!-- Composite End --></div>

</div>
</article>
</article>
<div id="dpsp-content-bottom" class="dpsp-content-wrapper dpsp-shape-rectangular dpsp-size-medium dpsp-show-on-mobile dpsp-button-style-1" style="min-height:40px;position:relative">
<ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-share dpsp-networks-btns-content dpsp-column-auto " style="padding:0;margin:0;list-style-type:none">
<li class="dpsp-network-list-item dpsp-network-list-item-facebook" style="float:left">
	<a rel="nofollow noopener" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D217458&#038;t=%27CASH%20IS%20KING%27%20ZAFRUL%20NOT%20WELCOME%20EVEN%20BY%20UMNO%20GRASSROOTS%20IN%20KUALA%20SELANGOR%20-%20%27WE%20HAVE%20BEEN%20WORKING%20HARD%20SINCE%202018%2C%20AND%20NOW%20HE%20COMES%20HERE%20AFTER%20WE%20HAVE%20DONE%20ALL%20THE%20WORK%27" class="dpsp-network-btn dpsp-facebook dpsp-first dpsp-has-label" target="_blank" aria-label="Share on Facebook" title="Share on Facebook" style="font-size:14px;padding:0rem;max-height:40px" >	<span class="dpsp-network-icon "><br />
		<span class="dpsp-network-icon-inner" ><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 18 32"><path d="M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z"></path></svg></span><br />
	</span><br />
	<span class="dpsp-network-label">Facebook</span></a></li>
<li class="dpsp-network-list-item dpsp-network-list-item-twitter" style="float:left">
	<a rel="nofollow noopener" href="https://twitter.com/intent/tweet?text=%27CASH%20IS%20KING%27%20ZAFRUL%20NOT%20WELCOME%20EVEN%20BY%20UMNO%20GRASSROOTS%20IN%20KUALA%20SELANGOR%20-%20%27WE%20HAVE%20BEEN%20WORKING%20HARD%20SINCE%202018%2C%20AND%20NOW%20HE%20COMES%20HERE%20AFTER%20WE%20HAVE%20DONE%20ALL%20THE%20WORK%27&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D217458" class="dpsp-network-btn dpsp-twitter dpsp-has-label" target="_blank" aria-label="Share on Twitter" title="Share on Twitter" style="font-size:14px;padding:0rem;max-height:40px" >	<span class="dpsp-network-icon "><br />
		<span class="dpsp-network-icon-inner" ><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 30 32"><path d="M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z"></path></svg></span><br />
	</span><br />
	<span class="dpsp-network-label">Twitter</span></a></li>
<li class="dpsp-network-list-item dpsp-network-list-item-linkedin" style="float:left">
	<a rel="nofollow noopener" href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D217458&#038;title=%27CASH%20IS%20KING%27%20ZAFRUL%20NOT%20WELCOME%20EVEN%20BY%20UMNO%20GRASSROOTS%20IN%20KUALA%20SELANGOR%20-%20%27WE%20HAVE%20BEEN%20WORKING%20HARD%20SINCE%202018%2C%20AND%20NOW%20HE%20COMES%20HERE%20AFTER%20WE%20HAVE%20DONE%20ALL%20THE%20WORK%27&#038;summary=Focus%20on%20your%20job%2C%20not%20Kuala%20Selangor%2C%20Tengku%20Zafrul%20told%20FINANCE%20minister%20Tengku%20Zafrul%20Tengku%20Abdul%20Aziz%20should%20focus%20on%20his%20job%20and%20the%20economy%20and%20not%20try%20to%20woo%20voters%20in%20Kuala%20Selangor%2C%20said&#038;mini=true" class="dpsp-network-btn dpsp-linkedin dpsp-last dpsp-has-label" target="_blank" aria-label="Share on LinkedIn" title="Share on LinkedIn" style="font-size:14px;padding:0rem;max-height:40px" >	<span class="dpsp-network-icon "><br />
		<span class="dpsp-network-icon-inner" ><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 27 32"><path d="M6.24 11.168v17.696h-5.888v-17.696h5.888zM6.624 5.696q0 1.312-0.928 2.176t-2.4 0.864h-0.032q-1.472 0-2.368-0.864t-0.896-2.176 0.928-2.176 2.4-0.864 2.368 0.864 0.928 2.176zM27.424 18.72v10.144h-5.856v-9.472q0-1.888-0.736-2.944t-2.272-1.056q-1.12 0-1.856 0.608t-1.152 1.536q-0.192 0.544-0.192 1.44v9.888h-5.888q0.032-7.136 0.032-11.552t0-5.28l-0.032-0.864h5.888v2.56h-0.032q0.352-0.576 0.736-0.992t0.992-0.928 1.568-0.768 2.048-0.288q3.040 0 4.896 2.016t1.856 5.952z"></path></svg></span><br />
	</span><br />
	<span class="dpsp-network-label">LinkedIn</span></a></li>
</ul>
</div>
<div class="fb-comments" data-href="https://www.malaysia-chronicle.com/?p=217458" data-width="100%" data-numposts="5" data-colorscheme="light" data-numposts="5" data-order-by="social"></div><!-- AI CONTENT END 1 -->
	</div>
			
</article><nav class="section-title clearfix" role="navigation">
<div class="post-nav left">
<a href="https://www.malaysia-chronicle.com/?p=217406" rel="prev">&larr; Previous article</a></div>
<div class="post-nav right">
<a href="https://www.malaysia-chronicle.com/?p=217447" rel="next">Next article &rarr;</a></div>
</nav>
 	</div>
	<aside class="sidebar sb-right">
    	
		<div class="sb-widget">
		<h4 class="widget-title">LATEST</h4>
		<ul>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=217464">BOMBSHELL &#8211; NO WONDER MALAYSIA IS DOOMED &#8211; IF THIS IS THE ATTITUDE &#038; QUALITY OF ITS TOP CIVIL SERVANT &#8211; I UNDERSTOOD 1MDB TO BE BN’S POLITICAL FUND SO I NEVER ASKED NAJIB ABOUT ITS CONTROVERSIES, CHIEF SECRETARY SIDEK TELLS COURT</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=217461">FOR DOING NOTHING FOR 5 YEARS, EX-TOP CIVIL SERVANT PAID RM30,000 MONTHLY &#8211; YET NAJIB FELT MOHD SIDEK&#8217;S PAY WAS &#8216;TOO LITTLE&#8217; &#8211; THIS IS HOW &#8216;BOSSKU&#8217; ON HIS OWN SQUANDERED THE NATION&#8217;S MONEY &#8211; DON&#8217;T BLAME JHO LOW FOR EVERYTHING!</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=217469">&#8216;SOME WERE TASERED, I WAS HIT ALL OVER MY BODY&#8217; &#8211; MALAYSIAN TEENAGER AH HENG FORCED TO BECOME A SCAMMER AFTER FALLING FOR RM4,000 A MONTH JOB AD</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=217442">BOMBSHELL &#8211; &#8216;INDUCED INSTABILITY&#8217; IN THE COMING MONTHS &#8211; MALAYSIANS BRACE FOR ANOTHER POLITICAL EARTHQUAKE &#8211; AS DESPERATION OVERTAKES &#8216;JAIL-BOUND&#8217; NAJIB &#038; ZAHID &#8211; EVEN MALAYS ARE WORRIED OF AN ECONOMIC WINTER AS GLOBAL STORMS BLOW IN &#8211; INDEED OF WHAT GOOD IS UMNO OTHER THAN CORRUPTION, INFIGHTING, DOUBLE-CROSSING, TREACHERY &#038; BETRAYAL?</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=217445">WHEN U.S. &#038; ALLIES GET SWELL-HEADED &#038; INSIST THE WORLD BELONGS TO THEM, THIS TYPE OF &#8216;NONSENSE&#8217; HAPPENS &#8211; &#8216;WE HAVE 100 YEARS&#8217; WORTH OF OIL&#8230;AND BIDEN WANTS TO FLY TO SAUDI ARABIA &#038; BEG THEM TO GIVE US ANOTHER HALF A MILLION BARRELS AT $120 A BARREL… IT MAKES NO SENSE,&#8217; BILLIONAIRE OIL REFINER WARNS THINGS WILL GET WORSE &#8211; INDEED, BECAUSE GEOPOLITICS IS PUT AHEAD OF ECONOMIES &#038; HUMAN WELL-BEING &#8211; NOTHING THEY DO IS SINCERE, EVERYTHING IS WEAPONISED TO GRAB SOME GAIN, SUPPRESS THEIR RIVALS</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=217454">NOW, PAS MINISTER TELLS MUSLIMS NOT TO TAKE PART IN &#8216;BON ODORI&#8217; FESTIVAL TO BE HELD IN SELANGOR DUE TO &#8216;RELIGIOUS ELEMENTS&#8217; &#8211; LUCKILY, THE QUEEN&#8217;S JUBILEE IS OVER OR WILL PAS SUDDENLY REALIZE BRITAIN IS A CHRISTIAN COUNTRY</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=217447">CHINA&#8217;S &#8216;EATING ECONOMY&#8217; IS BACK IN FULL SWING &#8211; &#8216;FOOD IS THE PARAMOUNT NECESSITY OF THE PEOPLE IN CHINA&#8217;</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=217458" aria-current="page">&#8216;CASH IS KING&#8217; ZAFRUL NOT WELCOME EVEN BY UMNO GRASSROOTS IN KUALA SELANGOR &#8211; &#8216;WE HAVE BEEN WORKING HARD SINCE 2018, AND NOW HE COMES HERE AFTER WE HAVE DONE ALL THE WORK&#8217;</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=217406">CAUGHT SPYING, U.S. DEPUTY SHERIFFS AUSTRALIA &#038; CANADA TURN CRY-BABIES &#8211; AS CHINA UPS THE ANTE ON THEIR DOUBLE-STANDARDS &#8211; FINALLY BREAKING SILENCE, BEIJING TELLS WHY CHINESE JET &#8216;HARASSED&#8217; AUSSIE &#038; CANADIAN SPY PLANES &#8211; INDEED, IF YOU CAN&#8217;T STAND THE HEAT, GET OUT OF THE KITCHEN!</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=217419">IF IT&#8217;S NOT THE CHINESE, IT&#8217;S ANWAR OR NAJIB &#8211; THAT&#8217;S MAHATHIR FOR YOU! &#8211; AND IT&#8217;S SAD THAT AFTER SUCH A LONG JOURNEY IN LIFE, THAT&#8217;S ALL THAT &#8216;OLD HORSE&#8217; MAHATHIR SEEMS TO KNOW! &#8211; AND THE SAME GOES FOR ANWAR &#038; NAJIB &#8211; AFTER ALL THESE YEARS, THEY ARE STILL PM-WANNABES FOR VAIN OR DESPERATE REASONS OF THEIR OWN</a>
									</li>
					</ul>

		</div><div class="sp-widget"><!--  ad tags Size: 160x600 ZoneId:1167412-->
<script type="text/javascript" src="https://js.genieessp.com/t/167/412/a1167412.js"></script>  </div>     
	</aside>
</div> 
</div>



<!--  ad tags Size: 300x250 ZoneId:1088371-->
<script type="text/javascript" src="https://js.genieessp.com/t/088/371/a1088371.js"></script>

<div class="copyright-wrap">
	<p class="copyright">Copyright &copy; 2022 | Malaysia Chronicle</p>

<!--  ad tags Size: 728x90 ZoneId:1143930-->
<script type="text/javascript" src="https://js.genieessp.com/t/143/930/a1143930.js"></script>
