<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
<meta charset="UTF-8">
	<title>Malaysia Chronicle</title>
	<meta name='robots' content='max-image-preview:large' />
<!-- Grow Social by Mediavine v.1.20.0 https://marketplace.mediavine.com/grow-social-pro/ -->
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="BELIEVE IT OR NOT - &#039;LOW CREDIBILITY&#039; ISMAIL SABRI WANTS TO &#039;CLIP&#039; THE POWERS OF THE AG - FOR THES AKE OF &#039;GOOD GOVERNANCE&#039; - YET DID HE NOT JUST CONTROVERSIALLY APPOINT SCANDAL-TAINTED UMNO-MATE TAJUDDIN AS AMBASSADOR TO INDONESIA - JUST FOR POLITICAL SUPPORT?" />
<meta property="og:description" content="AG’s power may be clipped PUTRAJAYA: A law on political funding and separating the roles of the Attorney General and Public Prosecutor could soon be on the cards. Datuk Seri Ismail Sabri Yaakob, who chaired" />
<meta property="og:url" content="https://www.malaysia-chronicle.com/?p=216927" />
<meta property="og:site_name" content="Malaysia Chronicle" />
<meta property="og:updated_time" content="2022-05-20T10:04:34+00:00" />
<meta property="article:published_time" content="2022-05-20T09:41:10+00:00" />
<meta property="article:modified_time" content="2022-05-20T10:04:34+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="BELIEVE IT OR NOT - &#039;LOW CREDIBILITY&#039; ISMAIL SABRI WANTS TO &#039;CLIP&#039; THE POWERS OF THE AG - FOR THES AKE OF &#039;GOOD GOVERNANCE&#039; - YET DID HE NOT JUST CONTROVERSIALLY APPOINT SCANDAL-TAINTED UMNO-MATE TAJUDDIN AS AMBASSADOR TO INDONESIA - JUST FOR POLITICAL SUPPORT?" />
<meta name="twitter:description" content="AG’s power may be clipped PUTRAJAYA: A law on political funding and separating the roles of the Attorney General and Public Prosecutor could soon be on the cards. Datuk Seri Ismail Sabri Yaakob, who chaired" />
<meta property="og:image" content="https://www.malaysia-chronicle.com/wp-content/uploads/2022/04/1261996-14.jpg" />
<meta name="twitter:image" content="https://www.malaysia-chronicle.com/wp-content/uploads/2022/04/1261996-14.jpg" />
<meta property="og:image:width" content="616" />
<meta property="og:image:height" content="344" />
<!-- Grow Social by Mediavine v.1.20.0 https://marketplace.mediavine.com/grow-social-pro/ -->
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans">
<link rel="stylesheet" href="https://www.malaysia-chronicle.com/wp-content/themes/mnews/style.css" media="screen">
<link rel="pingback" href="https://www.malaysia-chronicle.com/xmlrpc.php"/>
<link rel="shortcut icon" href="https://www.malaysia-chronicle.com/wp-content/themes/mnews/images/favicon.ico" type="image/x-icon" />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//cdn.innity.net' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; Feed" href="https://www.malaysia-chronicle.com/?feed=rss2" />
<link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; Comments Feed" href="https://www.malaysia-chronicle.com/?feed=comments-rss2" />
<link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; BELIEVE IT OR NOT &#8211; &#8216;LOW CREDIBILITY&#8217; ISMAIL SABRI WANTS TO &#8216;CLIP&#8217; THE POWERS OF THE AG &#8211; FOR THES AKE OF &#8216;GOOD GOVERNANCE&#8217; &#8211; YET DID HE NOT JUST CONTROVERSIALLY APPOINT SCANDAL-TAINTED UMNO-MATE TAJUDDIN AS AMBASSADOR TO INDONESIA &#8211; JUST FOR POLITICAL SUPPORT? Comments Feed" href="https://www.malaysia-chronicle.com/?feed=rss2&#038;p=216927" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.malaysia-chronicle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.4"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.malaysia-chronicle.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='dpsp-frontend-style-pro-css'  href='https://www.malaysia-chronicle.com/wp-content/plugins/social-pug/assets/dist/style-frontend-pro.1.20.0.css?ver=1.20.0' type='text/css' media='all' />
<link rel='stylesheet' id='popular-widget-css'  href='https://www.malaysia-chronicle.com/wp-content/plugins/popular-widget/_css/pop-widget.css?ver=1.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='myStyleSheets-css'  href='https://www.malaysia-chronicle.com/wp-content/plugins/wp-latest-posts/css/wplp_front.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='myFonts-css'  href='https://fonts.googleapis.com/css?family=Raleway%3A400%2C500%2C600%2C700%2C800%2C900%7CAlegreya%3A400%2C400italic%2C700%2C700italic%2C900%2C900italic%7CVarela+Round&#038;subset=latin%2Clatin-ext&#038;ver=5.8.4' type='text/css' media='all' />
<script type='text/javascript' src="https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js?ver=5.8.4" id='jquery-js'></script>
<script type='text/javascript' src="https://code.jquery.com/jquery-migrate-1.2.1.min.js?ver=5.8.4" id='jquery migrate-js'></script>
<script type='text/javascript' src='https://www.malaysia-chronicle.com/wp-content/themes/mnews/js/scripts.js?ver=5.8.4' id='scripts-js'></script>
<script type='text/javascript' src='https://www.malaysia-chronicle.com/wp-content/themes/mnews/js/jquery-news-ticker.js?ver=5.8.4' id='news-ticker-js'></script>
<script type='text/javascript' src="https://cdn.innity.net/admanager.js?ver=5.8.4" id='inniti-universal-js'></script>
<link rel="https://api.w.org/" href="https://www.malaysia-chronicle.com/index.php?rest_route=/" /><link rel="alternate" type="application/json" href="https://www.malaysia-chronicle.com/index.php?rest_route=/wp/v2/posts/216927" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.malaysia-chronicle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.malaysia-chronicle.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.4" />
<link rel="canonical" href="https://www.malaysia-chronicle.com/?p=216927" />
<link rel='shortlink' href='https://www.malaysia-chronicle.com/?p=216927' />
<link rel="alternate" type="application/json+oembed" href="https://www.malaysia-chronicle.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D216927" />
<link rel="alternate" type="text/xml+oembed" href="https://www.malaysia-chronicle.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D216927&#038;format=xml" />
	<div id="fb-root"></div>
	<script>(function(d, s, id) {
	  var js, fjs = d.getElementsByTagName(s)[0];
	  if (d.getElementById(id)) return;
	  js = d.createElement(s); js.id = id;
	  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=&version=v2.3";
	  fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));</script><style type="text/css" data-source="Grow Social by Mediavine">
				@media screen and ( max-width : 720px ) {
					.dpsp-content-wrapper.dpsp-hide-on-mobile,
					.dpsp-share-text.dpsp-hide-on-mobile,
					.dpsp-content-wrapper .dpsp-network-label {
						display: none;
					}
					.dpsp-has-spacing .dpsp-networks-btns-wrapper li {
						margin:0 2% 10px 0;
					}
					.dpsp-network-btn.dpsp-has-label:not(.dpsp-has-count) {
						max-height: 40px;
						padding: 0;
						justify-content: center;
					}
					.dpsp-content-wrapper.dpsp-size-small .dpsp-network-btn.dpsp-has-label:not(.dpsp-has-count){
						max-height: 32px;
					}
					.dpsp-content-wrapper.dpsp-size-large .dpsp-network-btn.dpsp-has-label:not(.dpsp-has-count){
						max-height: 46px;
					}
				}
			</style><style data-context="foundation-flickity-css">/*! Flickity v2.0.2
http://flickity.metafizzy.co
---------------------------------------------- */.flickity-enabled{position:relative}.flickity-enabled:focus{outline:0}.flickity-viewport{overflow:hidden;position:relative;height:100%}.flickity-slider{position:absolute;width:100%;height:100%}.flickity-enabled.is-draggable{-webkit-tap-highlight-color:transparent;tap-highlight-color:transparent;-webkit-user-select:none;-moz-user-select:none;-ms-user-select:none;user-select:none}.flickity-enabled.is-draggable .flickity-viewport{cursor:move;cursor:-webkit-grab;cursor:grab}.flickity-enabled.is-draggable .flickity-viewport.is-pointer-down{cursor:-webkit-grabbing;cursor:grabbing}.flickity-prev-next-button{position:absolute;top:50%;width:44px;height:44px;border:none;border-radius:50%;background:#fff;background:hsla(0,0%,100%,.75);cursor:pointer;-webkit-transform:translateY(-50%);transform:translateY(-50%)}.flickity-prev-next-button:hover{background:#fff}.flickity-prev-next-button:focus{outline:0;box-shadow:0 0 0 5px #09f}.flickity-prev-next-button:active{opacity:.6}.flickity-prev-next-button.previous{left:10px}.flickity-prev-next-button.next{right:10px}.flickity-rtl .flickity-prev-next-button.previous{left:auto;right:10px}.flickity-rtl .flickity-prev-next-button.next{right:auto;left:10px}.flickity-prev-next-button:disabled{opacity:.3;cursor:auto}.flickity-prev-next-button svg{position:absolute;left:20%;top:20%;width:60%;height:60%}.flickity-prev-next-button .arrow{fill:#333}.flickity-page-dots{position:absolute;width:100%;bottom:-25px;padding:0;margin:0;list-style:none;text-align:center;line-height:1}.flickity-rtl .flickity-page-dots{direction:rtl}.flickity-page-dots .dot{display:inline-block;width:10px;height:10px;margin:0 8px;background:#333;border-radius:50%;opacity:.25;cursor:pointer}.flickity-page-dots .dot.is-selected{opacity:1}</style><link rel="icon" href="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-270x270.jpg" />
<style>.ios7.web-app-mode.has-fixed header{ background-color: rgba(238,238,34,.88);}</style><style>
.ai-viewports                 {--ai: 1;}
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
	
	<!-- Place this code ONLY ONCE into the HEAD element of the web page -->
<script type="text/javascript" src="https://cdn.innity.net/admanager.js"></script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
	

</head>
	
	<body class="post-template-default single single-post postid-216927 single-format-standard"> 
	<div class="container">
		<header class="header-wrap">
			<div class="wrapper">
				<div class="logo-wrap" role="banner">
				<div class="logo">
<a href="https://www.malaysia-chronicle.com/" title="Malaysia Chronicle" rel="home">
</a>
</div>
					

					
									<div class="ad-topline">
						<div class="sp-widget"> <!-- Zone Tag : malaysiachronicle123 DESKTOP LEADERBOARD -->
<script type="text/javascript">
new innity_adZone("e077e1a544eec4f0307cf5c3c721d944", "94643", {"origin": "MY", "width": "728", "height": "90"});
</script> </div>					</div>
								</div>
			</div>
			<nav class="main-nav clearfix">	
				<div class="wrapper">
					<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-194847" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-194847"><a href="https://www.malaysia-chronicle.com/">Homepage</a></li>
<li id="menu-item-118482" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-118482"><a href="https://www.malaysia-chronicle.com/?cat=2">Politics</a></li>
<li id="menu-item-121976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121976"><a href="https://www.malaysia-chronicle.com/?cat=27">Malay</a></li>
<li id="menu-item-118484" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118484"><a href="https://www.malaysia-chronicle.com/?cat=3">Business</a></li>
<li id="menu-item-118485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118485"><a href="https://www.malaysia-chronicle.com/?cat=4">Social</a></li>
<li id="menu-item-118486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118486"><a href="https://www.malaysia-chronicle.com/?cat=7">Videos</a></li>
<li id="menu-item-120318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120318"><a href="https://www.malaysia-chronicle.com/?cat=6">Latest</a></li>
</ul></div>						<div class="search-box">
		<form role="search" method="get" id="searchform" action="">
			<fieldset>
				<input name="s" id="s" value="" autocomplete="off" placeholder="SEARCH" type="text">
				<input id="searchsubmit" value="" type="submit">
			</fieldset>
		</form>
	</div>				</div>
			</nav>
						


			
			
			
			
			

  <!-- Place this code where this unit should show in the page body -->
<!-- Zone Tag : malaysiachronicle123 Universal Tag_EN -->
<script type="text/javascript">
new innity_adZone("e077e1a544eec4f0307cf5c3c721d944", "41786", {"origin": "MY"});
</script> 			


</header>
	
							<div class="wrapper ad-leader1">
			<div class="sp-widget"><style>#M100146ScriptRootC1017239 {min-height: 300px;}</style>
<!-- Composite Start -->
<div id="M100146ScriptRootC1017239">
</div>
<script src="https://jsc.mgid.com/m/a/malaysia-chronicle.com.1017239.js" async></script>
<!-- Composite End --></div>			</div>
		
		
	 		
		
		<div class="wrapper clearfix">
	<div class="content left"><article class="post-216927 post type-post status-publish format-standard has-post-thumbnail hentry category-politics">
	<header class="post-header">			
		<h1 class="entry-title">BELIEVE IT OR NOT &#8211; &#8216;LOW CREDIBILITY&#8217; ISMAIL SABRI WANTS TO &#8216;CLIP&#8217; THE POWERS OF THE AG &#8211; FOR THES AKE OF &#8216;GOOD GOVERNANCE&#8217; &#8211; YET DID HE NOT JUST CONTROVERSIALLY APPOINT SCANDAL-TAINTED UMNO-MATE TAJUDDIN AS AMBASSADOR TO INDONESIA &#8211; JUST FOR POLITICAL SUPPORT?</h1>
				<p class="meta post-meta">
			<a href="https://www.malaysia-chronicle.com/?cat=2" rel="category">Politics</a>  |  
			<span class="updated">May 20, 2022 9:41 am</span> by 			<span class="vcard author">
							</span>  |  0 Comments</p>
	</header>
		<div class="entry clearfix">
		
<div class="post-thumbnail">
<a href="https://www.malaysia-chronicle.com/wp-content/uploads/2022/04/1261996-14.jpg" rel="prettyPhoto"><img src="https://www.malaysia-chronicle.com/wp-content/uploads/2022/04/1261996-14.jpg" alt="" title="1261996" /></a>
</div>
		<p>AG’s power may be clipped</p>
<p>PUTRAJAYA: A law on political funding and separating the roles of the Attorney General and Public Prosecutor could soon be on the cards.</p><div class='code-block code-block-4' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- Composite Start -->
<div id="M100146ScriptRootC1017224">
</div>
<script src="https://jsc.mgid.com/m/a/malaysia-chronicle.com.1017224.js" async></script>
<!-- Composite End --></div>

<p>Datuk Seri Ismail Sabri Yaakob, who chaired a meeting of the Special Cabinet Committee on Anti-Corruption here yesterday, said it was agreed that a Political Funding Act be put in place.</p>
<p><span style="color: #ff0000;"><strong>He said the Cabinet would deliberate on it before engaging with political parties.</strong></span></p>
<p><span style="color: #ff0000;"><strong>“This law is important because we want to prevent corruption and power abuse among politicians, which is detrimental to the government’s and country’s image,” the Prime Minister said in a statement released after the meeting.</strong></span></p>
<div class="inlineAd">
<div id="div-gpt-ad-Desktop_TSOL_News_SP_Mid_OSV" data-google-query-id="CJ6p6cP27PcCFcVKKwodfi0Axw">
<div id="google_ads_iframe_/21764785206/Desktop/Desktop_TSOL/Desktop_TSOL_News/Desktop_TSOL_News_SP_Mid/Desktop_TSOL_News_SP_Mid_OSV_0__container__">On <span style="color: #800080;"><strong>separating the office of the AG and Public Prosecutor, the Prime Minister said a study must be conducted before any decision is made as it involved the Federal Constitution, legal matters and finance.</strong></span></div>
</div>
</div>
<p>“The government remains committed to further improving governance and integrity,” he added.</p>
<p>There have been calls to separate the powers of the AG to remove political influence from the Malaysian criminal justice system.</p>
<p>In 2019, the Pakatan Harapan government announced that it would table a Political Funding Bill to focus on the regulatory aspects of political contributions.</p>
<p>Last year, Malaysian Anti-Corruption Commission (MACC) chief commissioner Tan Sri Azam Baki said although there was no specific law on political funding yet, the Governance, Integrity and Anti-Corruption Centre (GIACC) was preparing a draft.</p>
<p>Recently, the anti-corruption advisory board made several suggestions to the special committee on corruption, including enhancing laws to regulate political funding.</p>
<p>Ismail Sabri said the meeting also agreed for the National Financial Crime Centre (NFCC) to be the central agency to manage properties and possessions that were seized and forfeited.</p>
<p>He said it was important for the body to undertake the responsibility so that the war against financial crime and leakages of government revenue could be prevented.</p><div class='code-block code-block-7' style='margin: 8px 0; clear: both;'>
<!-- Composite Start -->
<div id="M100146ScriptRootC1018821">
</div>
<script src="https://jsc.mgid.com/m/a/malaysia-chronicle.com.1018821.js" async></script>
<!-- Composite End --></div>

<p>“This new policy on management involving seized and forfeited properties will allow enforcement agencies to focus more on investigation, particularly cases involving financial crimes,” he said.</p>
<p>The Prime Minister said of the 53 legislations involved, 26 needed to be amended, and said this needed to be given priority.</p>
<p>The NFCC was set up in 2018 to fight money laundering activities.</p>
<p>Ismail Sabri also said that a national plan on good governance to be known as MyGovernance will be introduced to further strengthen the public delivery system based on the principles of transparency, accountability, efficiency and effectiveness. ANN</p>
<div class="td-post-header">
<header class="td-post-title">
<h1 class="entry-title">Why choose controversial Tajuddin, Umno leader asks PM</h1>
</header>
</div>
<div class="td-post-content tagdiv-type">
<div id="st-1" class="sharethis-inline-share-buttons st-left st-has-labels st-inline-share-buttons st-animated">
<div class="st-btn st-last st-hide-label" data-network="email"><img src="https://platform-cdn.sharethis.com/img/email.svg" alt="email sharing button" /></div>
</div>
<figure id="attachment_1741370" class="wp-caption aligncenter"><img loading="lazy" class="wp-image-1741370 size-full" src="https://s3media.freemalaysiatoday.com/wp-content/uploads/2021/06/4_TAJUDDIN_ABDUL_RAHMAN_UMNO_PASIR_SALAK_PERAK_FMT_25062021.jpg" sizes="(max-width: 800px) 100vw, 800px" srcset="https://s3media.freemalaysiatoday.com/wp-content/uploads/2021/06/4_TAJUDDIN_ABDUL_RAHMAN_UMNO_PASIR_SALAK_PERAK_FMT_25062021.jpg 800w, https://s3media.freemalaysiatoday.com/wp-content/uploads/2021/06/4_TAJUDDIN_ABDUL_RAHMAN_UMNO_PASIR_SALAK_PERAK_FMT_25062021-300x188.jpg 300w, https://s3media.freemalaysiatoday.com/wp-content/uploads/2021/06/4_TAJUDDIN_ABDUL_RAHMAN_UMNO_PASIR_SALAK_PERAK_FMT_25062021-768x480.jpg 768w, https://s3media.freemalaysiatoday.com/wp-content/uploads/2021/06/4_TAJUDDIN_ABDUL_RAHMAN_UMNO_PASIR_SALAK_PERAK_FMT_25062021-696x435.jpg 696w, https://s3media.freemalaysiatoday.com/wp-content/uploads/2021/06/4_TAJUDDIN_ABDUL_RAHMAN_UMNO_PASIR_SALAK_PERAK_FMT_25062021-672x420.jpg 672w" alt="" width="800" height="500" data-kiosked-context-name="kskdUIContext_01g3fhryh3q501ehmyb5ker7dp" /><figcaption class="wp-caption-text">Tajuddin Abdul Rahman is not noted for any extraordinary ability, says an Umno leader.</figcaption></figure>
<p>PETALING JAYA: An Umno leader has criticised the appointment of Pasir Salak MP Tajuddin Abdul Rahman to the position of ambassador to Indonesia, saying Prime Minister Ismail Sabri Yaakob should have chosen a less controversial figure.</p>
<p>The leader, who spoke on condition of anonymity, told FMT he could understand the prime minister’s need to pick a party colleague he could trust, but said <span style="color: #ff0000;"><strong>Tajuddin was not noted for any extraordinary ability.</strong></span></p>
<div id="div-gpt-ad-1608712148585-0" data-google-query-id="CJ38n7f47PcCFQKojwod118LRw">
<div id="google_ads_iframe_/1009103/FMT_In_Article_Midrec_0__container__">In fact, he said, his abilities were questionable, as shown in his handling of a collision involving two LRT trains last year as the Prasarana chairman.</div>
</div>
<p data-kiosked-context-name="kskdUIContext_01g3fhryh89epbna2xayky9gt6">“And why does the prime minister need to appoint a sitting MP when MPs are supposed to serve their constituents?”</p>
<p><span style="color: #ff0000;"><strong>He said Tajuddin’s “uncouth behaviour” in the Dewan Rakyat also made him unfit for a diplomat’s job.</strong></span></p>
<p>However, he also said the appointment did not mean that Umno had gone back to its old ways of giving perks and top positions in government to the politically connected.</p>
<p>“Umno is staying on track for political reform,” he said. “We support the anti-hopping law, given equal constituency development funds in Perak, amended our party’s constitution and fielded more younger candidates in the last two state elections.”</p>
<p>On Wednesday, Ismail defended Tajuddin’s appointment, saying Putrajaya “cannot satisfy everybody”.</p>
<p>He also said Tajuddin was a seasoned politician and that his appointment had been approved by Indonesian President Joko Widodo.</p>
<p data-kiosked-context-name="kskdUIContext_01g3fhryh89epbna2xayky9gt6">Political analyst Azmi Hassan of Akademi Nusantara said Umno seemed to be distancing itself from Tajuddin, adding that the party could not be blamed for his appointment.</p>
<p>He told FMT he noticed that Umno had not been in support of Tajuddin on “any political matter”, especially after the LRT debacle.</p>
<p>“I see that Umno is also distancing itself from his ambassadorial appointment,” he said.</p>
<p>Political scientist Wong Chin Huat said the practice of appointing political figures as diplomats was flawed but had been going on for years, even when Pakatan Harapan was in power.</p>
<p>“Umno parliamentarians will not criticise this practice even if they think Tajuddin is not qualified as they, too, would want such golden handshakes on their way out,” he said.  FMT</p>
</div>
<p>ANN  / FREE MALAYSIA TODAY</p>
<p>.</p><div class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<!-- Composite Start -->
<div id="M100146ScriptRootC1018808">
</div>
<script src="https://jsc.mgid.com/m/a/malaysia-chronicle.com.1018808.js" async></script>
<!-- Composite End -->

<!-- Composite Start -->
<div id="M100146ScriptRootC43439">
</div>
<script src="https://jsc.mgid.com/m/a/malaysia-chronicle.com.43439.js" async></script>
<!-- Composite End --></div>

<div id="dpsp-content-bottom" class="dpsp-content-wrapper dpsp-shape-rectangular dpsp-size-medium dpsp-show-on-mobile dpsp-button-style-1" style="min-height:40px;position:relative">
<ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-share dpsp-networks-btns-content dpsp-column-auto " style="padding:0;margin:0;list-style-type:none">
<li class="dpsp-network-list-item dpsp-network-list-item-facebook" style="float:left">
	<a rel="nofollow noopener" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D216927&#038;t=BELIEVE%20IT%20OR%20NOT%20-%20%27LOW%20CREDIBILITY%27%20ISMAIL%20SABRI%20WANTS%20TO%20%27CLIP%27%20THE%20POWERS%20OF%20THE%20AG%20-%20FOR%20THES%20AKE%20OF%20%27GOOD%20GOVERNANCE%27%20-%20YET%20DID%20HE%20NOT%20JUST%20CONTROVERSIALLY%20APPOINT%20SCANDAL-TAINTED%20UMNO-MATE%20TAJUDDIN%20AS%20AMBASSADOR%20TO%20INDONESIA%20-%20JUST%20FOR%20POLITICAL%20SUPPORT%3F" class="dpsp-network-btn dpsp-facebook dpsp-first dpsp-has-label" target="_blank" aria-label="Share on Facebook" title="Share on Facebook" style="font-size:14px;padding:0rem;max-height:40px" >	<span class="dpsp-network-icon "><br />
		<span class="dpsp-network-icon-inner" ><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 18 32"><path d="M17.12 0.224v4.704h-2.784q-1.536 0-2.080 0.64t-0.544 1.92v3.392h5.248l-0.704 5.28h-4.544v13.568h-5.472v-13.568h-4.544v-5.28h4.544v-3.904q0-3.328 1.856-5.152t4.96-1.824q2.624 0 4.064 0.224z"></path></svg></span><br />
	</span><br />
	<span class="dpsp-network-label">Facebook</span></a></li>
<li class="dpsp-network-list-item dpsp-network-list-item-twitter" style="float:left">
	<a rel="nofollow noopener" href="https://twitter.com/intent/tweet?text=BELIEVE%20IT%20OR%20NOT%20-%20%27LOW%20CREDIBILITY%27%20ISMAIL%20SABRI%20WANTS%20TO%20%27CLIP%27%20THE%20POWERS%20OF%20THE%20AG%20-%20FOR%20THES%20AKE%20OF%20%27GOOD%20GOVERNANCE%27%20-%20YET%20DID%20HE%20NOT%20JUST%20CONTROVERSIALLY%20APPOINT%20SCANDAL-TAINTED%20UMNO-MATE%20TAJUDDIN%20AS%20AMBASSADOR%20TO%20INDONESIA%20-%20JUST%20FOR%20POLITICAL%20SUPPORT%3F&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D216927" class="dpsp-network-btn dpsp-twitter dpsp-has-label" target="_blank" aria-label="Share on Twitter" title="Share on Twitter" style="font-size:14px;padding:0rem;max-height:40px" >	<span class="dpsp-network-icon "><br />
		<span class="dpsp-network-icon-inner" ><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 30 32"><path d="M28.928 7.296q-1.184 1.728-2.88 2.976 0 0.256 0 0.736 0 2.336-0.672 4.64t-2.048 4.448-3.296 3.744-4.608 2.624-5.792 0.96q-4.832 0-8.832-2.592 0.608 0.064 1.376 0.064 4.032 0 7.168-2.464-1.888-0.032-3.36-1.152t-2.048-2.848q0.608 0.096 1.088 0.096 0.768 0 1.536-0.192-2.016-0.416-3.328-1.984t-1.312-3.68v-0.064q1.216 0.672 2.624 0.736-1.184-0.8-1.888-2.048t-0.704-2.752q0-1.568 0.8-2.912 2.176 2.656 5.248 4.256t6.656 1.76q-0.16-0.672-0.16-1.312 0-2.4 1.696-4.064t4.064-1.696q2.528 0 4.224 1.824 1.952-0.384 3.68-1.408-0.672 2.048-2.56 3.2 1.664-0.192 3.328-0.896z"></path></svg></span><br />
	</span><br />
	<span class="dpsp-network-label">Twitter</span></a></li>
<li class="dpsp-network-list-item dpsp-network-list-item-linkedin" style="float:left">
	<a rel="nofollow noopener" href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D216927&#038;title=BELIEVE%20IT%20OR%20NOT%20-%20%27LOW%20CREDIBILITY%27%20ISMAIL%20SABRI%20WANTS%20TO%20%27CLIP%27%20THE%20POWERS%20OF%20THE%20AG%20-%20FOR%20THES%20AKE%20OF%20%27GOOD%20GOVERNANCE%27%20-%20YET%20DID%20HE%20NOT%20JUST%20CONTROVERSIALLY%20APPOINT%20SCANDAL-TAINTED%20UMNO-MATE%20TAJUDDIN%20AS%20AMBASSADOR%20TO%20INDONESIA%20-%20JUST%20FOR%20POLITICAL%20SUPPORT%3F&#038;summary=AG%E2%80%99s%20power%20may%20be%20clipped%20PUTRAJAYA%3A%20A%20law%20on%20political%20funding%20and%20separating%20the%20roles%20of%20the%20Attorney%20General%20and%20Public%20Prosecutor%20could%20soon%20be%20on%20the%20cards.%20Datuk%20Seri%20Ismail%20Sabri%20Yaakob%2C%20who%20chaired&#038;mini=true" class="dpsp-network-btn dpsp-linkedin dpsp-last dpsp-has-label" target="_blank" aria-label="Share on LinkedIn" title="Share on LinkedIn" style="font-size:14px;padding:0rem;max-height:40px" >	<span class="dpsp-network-icon "><br />
		<span class="dpsp-network-icon-inner" ><svg version="1.1" xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 27 32"><path d="M6.24 11.168v17.696h-5.888v-17.696h5.888zM6.624 5.696q0 1.312-0.928 2.176t-2.4 0.864h-0.032q-1.472 0-2.368-0.864t-0.896-2.176 0.928-2.176 2.4-0.864 2.368 0.864 0.928 2.176zM27.424 18.72v10.144h-5.856v-9.472q0-1.888-0.736-2.944t-2.272-1.056q-1.12 0-1.856 0.608t-1.152 1.536q-0.192 0.544-0.192 1.44v9.888h-5.888q0.032-7.136 0.032-11.552t0-5.28l-0.032-0.864h5.888v2.56h-0.032q0.352-0.576 0.736-0.992t0.992-0.928 1.568-0.768 2.048-0.288q3.040 0 4.896 2.016t1.856 5.952z"></path></svg></span><br />
	</span><br />
	<span class="dpsp-network-label">LinkedIn</span></a></li>
</ul>
</div>
<div class="fb-comments" data-href="https://www.malaysia-chronicle.com/?p=216927" data-width="100%" data-numposts="5" data-colorscheme="light" data-numposts="5" data-order-by="social"></div><!-- AI CONTENT END 1 -->
	</div>
			
</article><nav class="section-title clearfix" role="navigation">
<div class="post-nav left">
<a href="https://www.malaysia-chronicle.com/?p=216919" rel="prev">&larr; Previous article</a></div>
<div class="post-nav right">
<a href="https://www.malaysia-chronicle.com/?p=216931" rel="next">Next article &rarr;</a></div>
</nav>
 	</div>
	<aside class="sidebar sb-right">
    	
		<div class="sb-widget">
		<h4 class="widget-title">LATEST</h4>
		<ul>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=216935">NAJIB WANTS KIT SIANG ARRESTED &#8211; A DAY AFTER SENSATIONAL PIC OF HIMSELF &#038; MYSTERY WOMAN LINKING ARMS GOES VIRAL &#8211; ATTEMPT TO DEFLECT ATTENTION OR NOT, NAJIB WHO IS OFTEN CALLED A SERIAL LIAR ACCUSES KIT SIANG OF THE SAME OVER SRI LANKA COMPARISONS &#8211; &#8216;WHY THE NEED TO CONTINUE LYING &#038; INCITING THE PUBLIC?&#8217;</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=216937">UNABLE TO TOPPLE PUTIN &#8211; IS BIDEN NOW OUT TO SPARK WAR WITH CHINA? &#8211; INSTEAD OF TACKLING THE MOUNTING FUEL SHORTAGE IN U.S. WITH GAS STATIONS RUNNING OUT &#8211; BIDEN SUDDENLY WANTS TO INVITE TAIWAN TO WHO &#8211; KNOWING FULL WELL SUCH A STEP WILL BE VIGOROUSLY REJECTED BY BEIJING &#8211; IS BIDEN HOPING FOR A U.S.-CHINA WAR TO UNITE UNHAPPY &#038; WORRIED AMERICANS &#8211; AS THEY RUN OUT OF BABY FORMULA &#038; FUEL &#8211; WHILE NEVER-BEFORE-SEEN INFLATION, MASSIVE JOB LOSSES &#038; A MOTHER OF ALL RECESSIONS START TO SINK IN</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=216931">SELF-INFLICTED MOTHER OF ALL RECESSIONS TO HIT U.S. &#8211; &#8216;THIS TIME IT WON’T BE A DRESS REHEARSAL LIKE WITH COVID-19. THIS WILL BE THE REAL THING. TENS OF MILLIONS WILL BE FIRED FROM JOBS THAT WILL NEVER RETURN&#8217;</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=216927" aria-current="page">BELIEVE IT OR NOT &#8211; &#8216;LOW CREDIBILITY&#8217; ISMAIL SABRI WANTS TO &#8216;CLIP&#8217; THE POWERS OF THE AG &#8211; FOR THES AKE OF &#8216;GOOD GOVERNANCE&#8217; &#8211; YET DID HE NOT JUST CONTROVERSIALLY APPOINT SCANDAL-TAINTED UMNO-MATE TAJUDDIN AS AMBASSADOR TO INDONESIA &#8211; JUST FOR POLITICAL SUPPORT?</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=216919">ELON MUSK PREDICTS CHINA&#8217;S ECONOMY TO BE &#8216;TWO OR THREE TIMES&#8217; LARGER THAN AMERICA&#8217;S &#8211; EVEN AS BIDEN RAMPS UP SILLY BRINKMANSHIP GAMES &#8211; &#8216;WHAT WE’RE GOING TO SEE WITH CHINA IS AN ECONOMY THAT IS TWICE THE SIZE OF THE U.S., POSSIBLY THREE TIMES THE SIZE OF THE U.S&#8217;</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=216916">&#8216;RINGGIT REFLECTS THE SITUATION IN MALAYSIA &#8211; WHEN THE COUNTRY IS FULL OF CRAP, THEN THE RINGGIT WILL ALSO BECOME CRAP&#8217; &#8211; MALAYSIANS TELL &#8216;MAKCIK BANK NEGARA&#8217; TO BE CAREFUL ABOUT PEGGING THE RINGGIT &#8211; &#8216;DON&#8217;T BURN OUR FOREX RESERVES&#8217;</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=216911">WEDDING? NEW FAMILY? &#8211; NAJIB&#8217;S LOVE LIFE BACK IN SCRUTINY &#8211; BERSATU YOUTH CHIEF CONGRATULATES &#8216;BOSSKU&#8217; ON PURPORTED WEDDING &#8211; BUT IS IT TRUE OR FALSE? &#8211; NAJIB SHOULD CLEAR THE AIR AS RUMORS GO VIRAL &#8211; INSTEAD OF BOASTING ABOUT VISIT FROM SINGAPORE&#8217;S FOREIGN MINISTER</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=216900">BOMBSHELL &#8211; PIC OF NAJIB WITH MYSTERY WOMAN CLINGING TO HIS ARM GOES VIRAL &#8211; &#8216;HMM&#8230;SO, THE RUMOURS WERE INDEED TRUE?&#8217; &#8211; SURELY, ROSMAH HAS NOT BECOME A LIABILITY?</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=216897">BOMBSHELL &#8211; GIVING MALAYSIA ESPECIALLY MALAYS A BAD NAME FOR INSECURITY COMPLEX &#8211; WHILE JOKOWI RUSHED TO MEET ELON MUSK TO ADVANCE INDONESIA&#8217;S AGENDA – ISMAIL SABRI RUSHED HOME TO ATTEND SELF-PRAISE PARTY &#8211; IT WON&#8217;T BE LONG BEFORE INDONESIA STARTS TO IMPORT MALAYSIAN MAIDS! &#8211; BTW IF ISMAIL HAD MANAGED TO MEET ELON, WOULD THEY HAVE CONVERSED IN MALAY OR &#8216;ENGRISH&#8217;?</a>
									</li>
											<li>
					<a href="https://www.malaysia-chronicle.com/?p=216908">WHAT&#8217;S THIS, ZAHID! &#8211; INDEED, &#8216;SUNGAI BULOH&#8217; LOOMS NEARER FOR UMNO CHIEF &#8211; AS EX-COMPANY DIRECTOR ADMITS GIVING CASH TO ZAHID EVERY MONTH FOR 4 YEARS &#8211; STARTING FROM S$200K, TO $300K TO S$520K&#8230;</a>
									</li>
					</ul>

		</div><div class="sp-widget"><!--  ad tags Size: 160x600 ZoneId:1167412-->
<script type="text/javascript" src="https://js.genieessp.com/t/167/412/a1167412.js"></script>  </div>     
	</aside>
</div> 
</div>



<!--  ad tags Size: 300x250 ZoneId:1088371-->
<script type="text/javascript" src="https://js.genieessp.com/t/088/371/a1088371.js"></script>

<div class="copyright-wrap">
	<p class="copyright">Copyright &copy; 2022 | Malaysia Chronicle</p>

<!--  ad tags Size: 728x90 ZoneId:1143930-->
<script type="text/javascript" src="https://js.genieessp.com/t/143/930/a1143930.js"></script>
