<!DOCTYPE html><html class="no-js" lang="en-US"><head><meta charset="UTF-8"><link media="screen" href="https://www.malaysia-chronicle.com/wp-content/cache/autoptimize/autoptimize_04b51da1b601d1ef78596d816f104653.php" rel="stylesheet" /><link media="all" href="https://www.malaysia-chronicle.com/wp-content/cache/autoptimize/autoptimize_3a9273a57cd86f6788c3b9e2a9e5b687.php" rel="stylesheet" /><title>Malaysia Chronicle</title><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans"><link rel="pingback" href="https://www.malaysia-chronicle.com/xmlrpc.php"/><link rel="shortcut icon" href="https://www.malaysia-chronicle.com/wp-content/themes/mnews/images/favicon.ico" type="image/x-icon" /><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//code.jquery.com' /><link rel='dns-prefetch' href='//cdn.innity.net' /><link href='https://cdn.shortpixel.ai' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; Feed" href="https://www.malaysia-chronicle.com" /><link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; Comments Feed" href="https://www.malaysia-chronicle.com/?feed=comments-rss2" /><link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; BOMBSHELL &#8211; SODOMY &#8216;VICTIM&#8217; WAS PROMISED CASH FOR ALLOWING AZMIN TO USE HIS ACCUSATIONS AGAINST ANWAR, CLAIMS REPORT: BUT WILL MUHYIDDIN DARE ACT AGAINST AZMIN &#8211; WHO HAS HIM ON A LEASH WITH HIS GANG OF 10 MPs? IS IT NOT TIMELY FOR MUHYIDDIN TO DO THE RIGHT THING &#8211; AND REOPEN PROBE ON AZMIN&#8217;S OWN GAY SEX SCANDAL COVERED UP BY MAHATHIR &#8211; IF HE DOES NOT WANT TO BE BACKSTABBED &#038; DUMPED BY HIS SNEAKY SENIOR MINISTER Comments Feed" href="https://www.malaysia-chronicle.com/?feed=rss2&#038;p=193064" /> <script type='text/javascript' id='sfpp-fb-root-js-extra'>var sfpp_script_vars = {"language":"en_US","appId":"facebook.com\/wong.c.mei.1"};</script> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js' id='jquery-js'></script> <script type='text/javascript' src='https://code.jquery.com/jquery-migrate-1.2.1.min.js' id='jquery migrate-js'></script> <script type='text/javascript' src='https://cdn.innity.net/admanager.js' id='inniti-universal-js'></script> <link rel="https://api.w.org/" href="https://www.malaysia-chronicle.com/index.php?rest_route=/" /><link rel="alternate" type="application/json" href="https://www.malaysia-chronicle.com/index.php?rest_route=/wp/v2/posts/193064" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.malaysia-chronicle.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.malaysia-chronicle.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='BOMBSHELL &#8211; OPEN SEASON FOR CRIME IN MALAYSIA &#8211; BUT ONLY FOR MUHYIDDIN&#8217;S MPs: THEY CAN CARRY ON BREAKING LAWS &#8211; BUT COUP PM WILL ONLY FINE THEM RM1,000 &#038; NO JAIL &#8211; OR HE&#8217;LL LOSE HIS WAFER-THIN 111 &#8216;MAJORITY&#8217; &#8211; AND GET BOOTED OUT FOR GOOD!' href='https://www.malaysia-chronicle.com/?p=193058' /><link rel='next' title='NOW A NOBODY IN BERSATU, ALL EYES ON &#8216;FLYING CAR&#8217; REDZUAN TO FLY BACK TO MAHATHIR &#8211; AND JOIN PEJUANG: ALOR GAJAH MP THE BIGGEST LOSER IN BERSATU POLLS &#8211; PERHAPS, HE SHOULD HAVE STUCK WITH DR M LIKE SRI GADING MP SHAHRUDDIN INSTEAD OF U-TURN BACK TO MUHYIDDIN AT 11TH HOUR' href='https://www.malaysia-chronicle.com/?p=193073' /><meta name="generator" content="WordPress 5.5" /><link rel="canonical" href="https://www.malaysia-chronicle.com/?p=193064" /><link rel='shortlink' href='https://www.malaysia-chronicle.com/?p=193064' /><link rel="alternate" type="application/json+oembed" href="https://www.malaysia-chronicle.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D193064" /><link rel="alternate" type="text/xml+oembed" href="https://www.malaysia-chronicle.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D193064&#038;format=xml" /><div id="fb-root"></div> <script>(function(d, s, id) {
	  var js, fjs = d.getElementsByTagName(s)[0];
	  if (d.getElementById(id)) return;
	  js = d.createElement(s); js.id = id;
	  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=&version=v2.3";
	  fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));</script><meta name="twitter:card" 		content="summary_large_image" /><meta property="og:url"			content="https://www.malaysia-chronicle.com/?p=193064" /><meta property="og:type"			content="article" /><meta property="og:title"			content="BOMBSHELL - SODOMY &#039;VICTIM&#039; WAS PROMISED CASH FOR ALLOWING AZMIN TO USE HIS ACCUSATIONS AGAINST ANWAR, CLAIMS REPORT: BUT WILL MUHYIDDIN DARE ACT AGAINST AZMIN - WHO HAS HIM ON A LEASH WITH HIS GANG OF 10 MPs? IS IT NOT TIMELY FOR MUHYIDDIN TO DO THE RIGHT THING - AND REOPEN PROBE ON AZMIN&#039;S OWN GAY SEX SCANDAL COVERED UP BY MAHATHIR - IF HE DOES NOT WANT TO BE BACKSTABBED &amp; DUMPED BY HIS SNEAKY SENIOR MINISTER" /><meta property="og:description" 	content="fter ‘PM8′ stabbed his boss in the back late February (through pretending to defend him)" /><meta property="og:image" 		content="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/TEST3-10.jpg" /><link rel="icon" href="https://cdn.shortpixel.ai/client/q_lossy,ret_img,w_32,h_32/https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-32x32.jpg" sizes="32x32" /><link rel="icon" href="https://cdn.shortpixel.ai/client/q_lossy,ret_img,w_192,h_192/https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-192x192.jpg" sizes="192x192" /><link rel="apple-touch-icon" href="https://cdn.shortpixel.ai/client/q_lossy,ret_img,w_180,h_180/https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-180x180.jpg" /><meta name="msapplication-TileImage" content="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/cropped-MC-MOBILE-6-270x270.jpg" /><meta data-pso-pv="1.2.1" data-pso-pt="singlePost" data-pso-th="1013ecffa1a1fbf51d72e12a83fe4e89">  <script type="text/javascript" src="https://cdn.innity.net/admanager.js"></script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-2711886266814791",
          enable_page_level_ads: true
     });</script> </head><body data-rsssl=1 class="post-template-default single single-post postid-193064 single-format-standard"><div class="container"><header class="header-wrap"><div class="wrapper"><div class="logo-wrap" role="banner"><div class="logo"> <a href="https://www.malaysia-chronicle.com/" title="Malaysia Chronicle" rel="home"> </a></div><div class="ad-topline"></div></div></div><nav class="main-nav clearfix"><div class="wrapper"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-118487" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home current-post-parent menu-item-118487"><a href="https://www.malaysia-chronicle.com/">Home</a></li><li id="menu-item-118482" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-118482"><a href="https://www.malaysia-chronicle.com/?cat=2">Politics</a></li><li id="menu-item-118484" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118484"><a href="https://www.malaysia-chronicle.com/?cat=3">Business</a></li><li id="menu-item-118485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118485"><a href="https://www.malaysia-chronicle.com/?cat=4">Social</a></li><li id="menu-item-121976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121976"><a href="https://www.malaysia-chronicle.com/?cat=27">Malay</a></li><li id="menu-item-118486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118486"><a href="https://www.malaysia-chronicle.com/?cat=7">Videos</a></li><li id="menu-item-120318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120318"><a href="https://www.malaysia-chronicle.com/?cat=6">Latest</a></li><li id="menu-item-124988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124988"><a href="https://www.malaysia-chronicle.com/?page_id=124986">Contact</a></li></ul></div><div class="search-box"><form role="search" method="get" id="searchform" action=""><fieldset> <input name="s" id="s" value="" autocomplete="off" placeholder="SEARCH" type="text"> <input id="searchsubmit" value="" type="submit"></fieldset></form></div></div></nav>  <script type="text/javascript">new innity_adZone("e077e1a544eec4f0307cf5c3c721d944", "41786", {"origin": "MY"});</script>  <script type="text/javascript" src="https://js.genieessp.com/t/166/863/a1166863.js"></script> </header><div class="wrapper ad-leader1"><div class="sp-widget"> <script type="text/javascript" src="https://js.genieessp.com/t/166/745/a1166745.js"></script> </div></div><div class="wrapper clearfix"><div class="content left"><article class="post-193064 post type-post status-publish format-standard has-post-thumbnail hentry category-politics"><header class="post-header"><h1 class="entry-title">BOMBSHELL &#8211; SODOMY &#8216;VICTIM&#8217; WAS PROMISED CASH FOR ALLOWING AZMIN TO USE HIS ACCUSATIONS AGAINST ANWAR, CLAIMS REPORT: BUT WILL MUHYIDDIN DARE ACT AGAINST AZMIN &#8211; WHO HAS HIM ON A LEASH WITH HIS GANG OF 10 MPs? IS IT NOT TIMELY FOR MUHYIDDIN TO DO THE RIGHT THING &#8211; AND REOPEN PROBE ON AZMIN&#8217;S OWN GAY SEX SCANDAL COVERED UP BY MAHATHIR &#8211; IF HE DOES NOT WANT TO BE BACKSTABBED &#038; DUMPED BY HIS SNEAKY SENIOR MINISTER</h1><p class="meta post-meta"> <a href="https://www.malaysia-chronicle.com/?cat=2" rel="category">Politics</a> | <span class="updated">August 23, 2020</span> by <span class="vcard author"> </span> |  0 Comments</p></header><div class="entry clearfix"><div class="post-thumbnail"> <a href="https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/TEST3-10.jpg" rel="prettyPhoto"><img src="https://cdn.shortpixel.ai/client/q_lossy,ret_img/https://www.malaysia-chronicle.com/wp-content/uploads/2020/08/TEST3-10.jpg" alt="" title="TEST3" /></a></div><p>fter ‘PM8′ stabbed his boss in the back late February (through pretending to defend him) the cry was up that he would introduce an ‘<a href="https://www.bloomberg.com/news/articles/2020-03-03/new-malaysia-leader-says-he-s-no-traitor-vows-to-fight-graft">Anti-corruption Government</a>‘. This last week he instead conceded that he is bringing things “<a href="https://www.pmo.gov.my/2020/08/government-vows-to-bring-the-country-back-to-normal-pm-muhyiddin/">back to normal</a>‘.</p><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'>  <script type="text/javascript" src="https://js.genieessp.com/t/427/594/a1427594.js"></script></div><p>Everyone knows what that means when it comes to politics in Malaysia.</p><div class='code-block code-block-4' style='margin: 8px auto; text-align: center; display: block; clear: both;'>  <script type="text/javascript" src="https://js.genieessp.com/t/345/500/a1345500.js"></script></div><div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'><div id="jubna5045"></div> <script type="text/javascript">(function() {
var params =
{
id: "ac64e36d-03a7503c-a7383c82-3fd2f319",
d: "YWJvdWRjcm0uY29t",
cb: ((new Date()).valueOf().toString())
};
var qs="";
for(var key in params){qs+=key+"="+params[key]+"&"}
qs=qs.substring(0,qs.length-1);
var s = document.createElement("script");
s.type= "text/javascript";
s.setAttribute("data-cfasyn", "false");
s.src = "https://jubnaadserve.com/en/api/widget/5045?" + qs;
s.async = true;
document.getElementById("jubna5045").appendChild(s);
})();</script> </div><p>A recording later proved the point, as he was heard strategising how to buy and bribe defectors using ministerial posts and illegal appointments to GLCs (all of which took place).</p><p>As for the rest? Naturally, the criminally charged kleptocrats from UMNO and the high-living prelates from PAS were only too eager to steer the way and take over the show – after all whom does decapitated Bersatu now really represent?</p><p>As a result, Malaysia is being run by the same old mafia politicians, treating the public to the same tired stories and shows of yore, all brought courtesy of the same post-retirement performers – prime amongst them ‘NGO Leader’ cum bankrupt, Ramesh Rao and ‘Investigative Journalist’ cum bankrupt, Raja Petra Kamaruddin (RPK).</p><p>Both have ended up subjects (yet again) of a police report today and Malaysians need no prompting to understand that at issue is a ‘Statutory Declaration’ first orchestrated into existence by Ramesh Rao and then ‘exposed’ by RPK on his site (who else would touch it?).</p><p><span style="color: #ff0000;"><strong>Rao (who once <a style="color: #ff0000;" href="https://www.sarawakreport.org/2016/09/bn-ngo-leader-issues-death-threat-to-sarawak-report-editor-as-pahang-mb-gets-the-chop/">threatened to “burn alive”</a> the editor of Sarawak Report) is an enthusiast of Rosmah Mansor (<a style="color: #ff0000;" href="https://www.thestartv.com/v/ramesh-rao-breaks-down-at-rosmah-s-vigil">a mother to him</a>). As the police report against him alleges, he persuaded the complainant, one Aidil Azim, to notarise a statutory declaration in June claiming Aidil had been paid for sex by UMNO’s prize target and repeated victim of gay sex accusations, the PKR leader Anwar Ibrahim.</strong></span></p><p><span style="color: #ff0000;"><strong>Azim <a style="color: #ff0000;" href="https://www.malaysiakini.com/news/539383">says he was promised cash</a> in return for allowing the would-be PKR leadership usurper and then defector Azmin Ali to utilise the declaration in some undisclosed way. Instead the document was given to RPK who published it and embarrassed Azim.</strong></span></p><p>Who knows at this stage if any of what Azim alleges might be true? What he describes in his SD supposedly took place back in 2013 yet no concrete evidence has been provided even though the complainant, who claims he willingly did the job several times for money, must have known that Malaysia is seething with Anwar’s political enemies all desperate to just prove such an accusation.</p><p><span style="color: #ff0000;"><strong>What we do know is that we absolutely cannot trust the word of either Ramesh Rao or Raja Petra Kamaruddin (RPK).</strong></span></p><p><img src="https://www.sarawakreport.org/cache/e/0/2/7/6/e02764915716329554f4066801d2b92f0d61abaf.jpg" alt="'Back To Normal' With The Same Tired Tricksters And Their Same Old Playbook - Of Sex, Lies and Videotape" /></p><p>Ramesh Rao is a habitual concoctor of fake confessions and is so bad at it he has been caught out time and again. When Sarawak Report became a target of a Ramesh Rao operation a former journalist, Sarawakian <a href="https://www.sarawakreport.org/2015/07/ramesh-rao-also-bankrupt-so-who-is-paying/">Lester Melanyi, openly admitted he was paid </a>to make ridiculous allegations of forgery to undermine our exposes on 1MDB.</p><p>Lester was a sick and desperate man at the time, who sadly has since died. Rao had offered him money and Lester gamely earned it by <a href="https://www.sarawakreport.org/2015/07/lester-melanyi-debunked/">issuing his string of lies</a>, which were all easily disproved. Ramesh Rao walked away, but Lester became a laughing stock.</p><p>Before that Rao ruined another family’s life, when he acted as go-between to PI Bala after  his Statutory Declaration over the Altantuya case on behalf of Rosmah and Najib. As all Malaysia knows Najib and family members bribed and blackmailed Bala to change his story and take his family into exile</p><p>As ever, it was a lie. Bala later returned and revealed how he was bullied into changing his original declaration. Not long after Bala sadly also died. However, Rao was by no means done. As the 1MDB case started to explode it was none other than Ramesh Rao who again <a href="https://www.sarawakreport.org/2016/03/exclusive-evidence-how-bn-bribed-bala-widow-to-apologise-to-najib-and-rosmah/">enticed Bala’s desperate widow to accept his cas</a>h in return for a statement retracting statements against Rosmah and Najib.</p><p>Except, Rao altered the statement she had been prepared to give, so she retracted it live, on camera at the very press conference they had called to pull off the stunt. It meant yet again the Ramesh Rao fake confession tactic exploded in his face and made matters worse for his patrons, by now well known to be Rosmah and Najib.</p><p>Rao’s loyalties are not in doubt. He broke down in emotion at Rosmah’s trial (at the very least the bankrupt would have been concerned at losing a likely key donor for the good works of his ‘NGO’) and at Najib’s conviction he posted libellous tweets against the judge for which he was questioned by police over contempt of court.</p><p>So little surprise, now things are ‘back to normal’, that Ramesh Rao is back peddling his trusty sideline in staged confessions. The surprise would be if this time any of it turned out to hold a shred of truth.</p><h3><span style="color: #ff0000;"><strong>Another Routine Performer</strong></span></h3><p>So what of the publisher of all this ‘information’?  In Najib’s cheerleader RPK once again we have an all too familiar player following a familiar playbook. For years this blogger has proved an incontinent producer of wild and unverified defamation directed against those he has admitted he is paid to vilify.</p><p>Grainy and unverified video are as much his stock in trade as dodgy documents that are uncorroborated by evidence or facts.</p><p>In the past ‘RPK’ has accused Rosmah of commissioning murder and much more recently Azmin Ali of stealing hundreds of millions of ringgit.  Following re-alignments he has changed his tune towards them both and acts their agent.</p><p>Meanwhile, he has accused Sarawak Report, opposition leader Lim Guan Eng and countless others of largely unsubstantiated nonsense.</p><p>He hides in the UK to avoid legal action from angry targets.  However, he ought be wary that with his present story he is highly vulnerable under UK law, whether his allegations prove true or false. Since if what he claims were to be correct, he could be found guilty of an invasion of privacy, harassment and hate crime against consenting adults. If false, of gross libel exacerbated by homophobia.</p><p><span style="color: #ff0000;"><strong>So, once again, Malaysia has to stomach political vendetta waged through the agency of well known proven liars, employing the same old tired tactics without a shred of evidence so far to prove their tawdry accusations.</strong></span></p><p><span style="color: #ff0000;"><strong>The fact that the man accused of commissioning all the fun, PKR defector Azmin Ali, was himself the recent target of exact same allegations but was saved from prosecution because  the previous government refused to stoop so low, only serves to remind how far backwards this back-end-obsessed coterie of outdated politicians has travelled since their backdoor coup overturned the elected government.</strong></span></p><p>It also demonstrates how they are out of fresh ideas, out of fresh faces and dependent on tired out dirty tactics as they try to get yesterday’s men off the hook over their corruption trials and grab whatever remaining loot that their return to abuse of power can provide them with.</p><p>SARAWAK REPORT</p><div class='code-block code-block-3' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>  <script type="text/javascript" src="https://js.genieessp.com/t/324/437/a1324437.js"></script></div><p>.</p><div class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'><div id="jubna3035"></div> <script type="text/javascript">(function() {
var params =
{
id: "ac64e36d-03a7503c-a7383c82-3fd2f319",
d: "YWJvdWRjcm0uY29t",
cb: ((new Date()).valueOf().toString())
}; 
var qs="";
for(var key in params){qs+=key+"="+params[key]+"&"}
qs=qs.substring(0,qs.length-1);
var s = document.createElement("script");
s.type= "text/javascript";
s.setAttribute("data-cfasyn", "false");
s.src = "https://jubna.com/en/api/widget/3035?" + qs;
s.async = true;
document.getElementById("jubna3035").appendChild(s);
})();</script> <div id="MarketGidScriptRootC43439"><div id="MarketGidPreloadC43439"> <a id="mg_add43439" href="http://mgid.com/advertisers/?utm_source=widget&utm_medium=text&utm_campaign=add" target="_blank">Place your ad here </a> <br> <a href="http://mgid.com/" target="_blank">Loading... </a></div> <script>(function(){ var D=new Date(),d=document,b='body',ce='createElement',ac='appendChild',st='style',ds='display',n='none',gi='getElementById'; var i=d[ce]('iframe');i[st][ds]=n;d[gi]("MarketGidScriptRootC43439")[ac](i);try{var iw=i.contentWindow.document;iw.open();iw.writeln("<ht"+"ml><bo"+"dy></bo"+"dy></ht"+"ml>");iw.close();var c=iw[b];} catch(e){var iw=d;var c=d[gi]("MarketGidScriptRootC43439");}var dv=iw[ce]('div');dv.id="MG_ID";dv[st][ds]=n;dv.innerHTML=43439;c[ac](dv); var s=iw[ce]('script');s.async='async';s.defer='defer';s.charset='utf-8';s.src="//jsc.mgid.com/m/a/malaysia-chronicle.com.43439.js?t="+D.getYear()+D.getMonth()+D.getDate()+D.getHours();c[ac](s);})();</script> </div></div><div id="dpsp-content-bottom" class="dpsp-content-wrapper dpsp-shape-rectangular dpsp-column-auto dpsp-show-on-mobile dpsp-button-style-1 dpsp-has-icon-background dpsp-has-button-background"><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-content "><li><a rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D193064&#038;t=BOMBSHELL%20-%20SODOMY%20%27VICTIM%27%20WAS%20PROMISED%20CASH%20FOR%20ALLOWING%20AZMIN%20TO%20USE%20HIS%20ACCUSATIONS%20AGAINST%20ANWAR%2C%20CLAIMS%20REPORT%3A%20BUT%20WILL%20MUHYIDDIN%20DARE%20ACT%20AGAINST%20AZMIN%20-%20WHO%20HAS%20HIM%20ON%20A%20LEASH%20WITH%20HIS%20GANG%20OF%2010%20MPs%3F%20IS%20IT%20NOT%20TIMELY%20FOR%20MUHYIDDIN%20TO%20DO%20THE%20RIGHT%20THING%20-%20AND%20REOPEN%20PROBE%20ON%20AZMIN%27S%20OWN%20GAY%20SEX%20SCANDAL%20COVERED%20UP%20BY%20MAHATHIR%20-%20IF%20HE%20DOES%20NOT%20WANT%20TO%20BE%20BACKSTABBED%20%26%20DUMPED%20BY%20HIS%20SNEAKY%20SENIOR%20MINISTER" class="dpsp-network-btn dpsp-facebook dpsp-first" title="Share on Facebook"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Facebook</span></span></a></li><li><a rel="nofollow" href="https://twitter.com/intent/tweet?text=BOMBSHELL%20-%20SODOMY%20%27VICTIM%27%20WAS%20PROMISED%20CASH%20FOR%20ALLOWING%20AZMIN%20TO%20USE%20HIS%20ACCUSATIONS%20AGAINST%20ANWAR%2C%20CLAIMS%20REPORT%3A%20BUT%20WILL%20MUHYIDDIN%20DARE%20ACT%20AGAINST%20AZMIN%20-%20WHO%20HAS%20HIM%20ON%20A%20LEASH%20WITH%20HIS%20GANG%20OF%2010%20MPs%3F%20IS%20IT%20NOT%20TIMELY%20FOR%20MUHYIDDIN%20TO%20DO%20THE%20RIGHT%20THING%20-%20AND%20REOPEN%20PROBE%20ON%20AZMIN%27S%20OWN%20GAY%20SEX%20SCANDAL%20COVERED%20UP%20BY%20MAHATHIR%20-%20IF%20HE%20DOES%20NOT%20WANT%20TO%20BE%20BACKSTABBED%20%26%20DUMPED%20BY%20HIS%20SNEAKY%20SENIOR%20MINISTER&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D193064" class="dpsp-network-btn dpsp-twitter" title="Share on Twitter"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Twitter</span></span></a></li><li><a rel="nofollow" href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D193064&#038;title=BOMBSHELL%20-%20SODOMY%20%27VICTIM%27%20WAS%20PROMISED%20CASH%20FOR%20ALLOWING%20AZMIN%20TO%20USE%20HIS%20ACCUSATIONS%20AGAINST%20ANWAR%2C%20CLAIMS%20REPORT%3A%20BUT%20WILL%20MUHYIDDIN%20DARE%20ACT%20AGAINST%20AZMIN%20-%20WHO%20HAS%20HIM%20ON%20A%20LEASH%20WITH%20HIS%20GANG%20OF%2010%20MPs%3F%20IS%20IT%20NOT%20TIMELY%20FOR%20MUHYIDDIN%20TO%20DO%20THE%20RIGHT%20THING%20-%20AND%20REOPEN%20PROBE%20ON%20AZMIN%27S%20OWN%20GAY%20SEX%20SCANDAL%20COVERED%20UP%20BY%20MAHATHIR%20-%20IF%20HE%20DOES%20NOT%20WANT%20TO%20BE%20BACKSTABBED%20%26%20DUMPED%20BY%20HIS%20SNEAKY%20SENIOR%20MINISTER&#038;mini=true" class="dpsp-network-btn dpsp-linkedin dpsp-last" title="Share on LinkedIn"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">LinkedIn</span></span></a></li></ul></div><div class="fb-comments" data-href="https://www.malaysia-chronicle.com/?p=193064" data-width="100%" data-numposts="5" data-colorscheme="light" data-numposts="5" data-order-by="social"></div></div></article><nav class="section-title clearfix" role="navigation"><div class="post-nav left"> <a href="https://www.malaysia-chronicle.com/?p=193058" rel="prev">&larr; Previous article</a></div><div class="post-nav right"> <a href="https://www.malaysia-chronicle.com/?p=193073" rel="next">Next article &rarr;</a></div></nav></div><aside class="sidebar sb-right"><div class="sp-widget"> <script type="text/javascript" src="https://js.genieessp.com/t/225/640/a1225640.js"></script> </div><div class="sb-widget"><h4 class="widget-title">LATEST</h4><ul><li> <a href="https://www.malaysia-chronicle.com/?p=193081">EVEN UMNO FINDS PAS &#8216;NO CLASS&#8217; &#8211; AND BY EXTENSION MUHYIDDIN&#8217;S COWARDLY SILENCE: UMNO SUPREME COUNCIL MEMBER DEMANDS &#8216;LEGAL ACTION&#8217; AS PETITION FOR KUALA NERUS MP&#8217;S RESIGNATION NEARS A STAGGERING 30,000 MARK</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=193079">HYPOCRITES, UNGRATEFUL &#038; ARROGANT, CRAWL OUT FROM THE AZMIN &#038; PAS WOODWORK: TRAITOROUS AZMIN CARTEL NOW UNDER MUHYIDDIN&#8217;S &#8216;PROTECTION&#8217; BASH PAKATAN &#8211; WHILE PAS BRUSHES OFF KHAIRUDDIN&#8217;S SKIPPING COVID-19 QUARANTINE WITH &#8216;WHAT&#8217;S THE BIG DEAL, HE DIDN&#8217;T CAUSE ANY CLUSTERS&#8217;</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=193071">UMNO GIVES IT TO MUHYIDDIN NICE &#038; HOT  &#8211;  WE ARE NO WHERE AS DIRTY AS BERSATU! ISMAIL SABRI BLOWS ALL OVER TOWN &#8216;NO DEFENCE FOR NEPOTISM&#8217; ON HIS BERSATU DEPUTY &#8211; WHO WAS GREEDY ENOUGH TO DARE ASK AN UMNO WARLORD FOR A SUPPORT LETTER FOR POSITIONS &#8211; EVEN AS PUBLIC OUTRAGE TRIGGERS CALLS FOR A &#8216;NAME &#038; SHAME&#8217;</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=193077">JUST LIKE NAJIB&#8217;S CHILDREN MUST BE SO &#8216;GRATEFUL&#8217; FOR HIS GRAND THIEVERY &#8211; SON OF BERSATU DEPUTY MINISTER ALSO &#8216;GRATEFUL&#8217; FOR DAD&#8217;S SUPPORT LETTER &#8211; WITHOUT ANY THOUGHT FOR THE THOUSANDS OF OTHERS QUALIFIED FOR THE SAME POST BUT UNABLE TO PULL CABLES OR RESORT TO ABUSE OF POWER &#038; NEPOTISM TO GAIN UNFAIR ADVANTAGE</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=193073">NOW A NOBODY IN BERSATU, ALL EYES ON &#8216;FLYING CAR&#8217; REDZUAN TO FLY BACK TO MAHATHIR &#8211; AND JOIN PEJUANG: ALOR GAJAH MP THE BIGGEST LOSER IN BERSATU POLLS &#8211; PERHAPS, HE SHOULD HAVE STUCK WITH DR M LIKE SRI GADING MP SHAHRUDDIN INSTEAD OF U-TURN BACK TO MUHYIDDIN AT 11TH HOUR</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=193064" aria-current="page">BOMBSHELL &#8211; SODOMY &#8216;VICTIM&#8217; WAS PROMISED CASH FOR ALLOWING AZMIN TO USE HIS ACCUSATIONS AGAINST ANWAR, CLAIMS REPORT: BUT WILL MUHYIDDIN DARE ACT AGAINST AZMIN &#8211; WHO HAS HIM ON A LEASH WITH HIS GANG OF 10 MPs? IS IT NOT TIMELY FOR MUHYIDDIN TO DO THE RIGHT THING &#8211; AND REOPEN PROBE ON AZMIN&#8217;S OWN GAY SEX SCANDAL COVERED UP BY MAHATHIR &#8211; IF HE DOES NOT WANT TO BE BACKSTABBED &#038; DUMPED BY HIS SNEAKY SENIOR MINISTER</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=193058">BOMBSHELL &#8211; OPEN SEASON FOR CRIME IN MALAYSIA &#8211; BUT ONLY FOR MUHYIDDIN&#8217;S MPs: THEY CAN CARRY ON BREAKING LAWS &#8211; BUT COUP PM WILL ONLY FINE THEM RM1,000 &#038; NO JAIL &#8211; OR HE&#8217;LL LOSE HIS WAFER-THIN 111 &#8216;MAJORITY&#8217; &#8211; AND GET BOOTED OUT FOR GOOD!</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=193068">THE SEEDY WORLD OF NAJIB &#038; JHO LOW &#8211; US$8 MILLION JUST TO LOBBY FOR A CHANCE TO BEG TRUMP TO LET HIM OFF THE 1MDB HOOK &#8211; BUT BY THEN EVEN TRUMP GOT SCARED OF NAJIB&#8217;S STINK &#038; CANCELLED &#8216;MOST EXPENSIVE EVER GOLF GAME&#8217;</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=193061">NOT READY FOR ELECTIONS &#8211; BUT READY TO GRAB POWER! IN MIMICKING HIS BENEFACTOR MUHYIDDIN, EX-CM MUSA AMAN &#038; GANG SHOW THEIR FEAR OF THE PEOPLE&#8217;S VERDICT</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=193056">AZMIN&#8217;S DECISION TO JOIN MUHYIDDIN WAS TO &#8216;SAVE RACE &#038; COUNTRY&#8217;: REJECTED &#038; HATED NATIONWIDE FOR THEIR POLITICS OF LIES &#038; BETRAYAL, AZMIN CARTEL NOW PORTRAY THEMSELVES AS DEFENDERS OF MALAY RACE &#8211; EVEN AS &#8216;SPEAKING AS CHINESE COMMUNITY REP&#8217; LEE CHIN CHEH URGES BERSATU TO OPEN DOORS TO ALL RACES &#8211; BUT HASN&#8217;T CARTEL-MATE EDMUND SANTHARA ALREADY JOINED?</a></li></ul></div><div class="sp-widget"> <script type="text/javascript" src="https://js.genieessp.com/t/167/412/a1167412.js"></script> </div></aside></div></div>  <script type="text/javascript" src="https://js.genieessp.com/t/088/371/a1088371.js"></script> <div class="copyright-wrap"><p class="copyright">Copyright &copy; 2020 | Malaysia Chronicle</p>   <script type="text/javascript" src="https://js.genieessp.com/t/143/930/a1143930.js"></script> <script defer src="https://www.malaysia-chronicle.com/wp-content/cache/autoptimize/autoptimize_90beaeb8d38298ad07160fcdda86e109.php"></script><!--noptimize--><!-- Autoptimize found a problem with the HTML in your Theme, tag `/body` missing --><!--/noptimize-->