<!DOCTYPE html><html class="no-js" lang="en-US"><head><meta charset="UTF-8"><link media="screen" href="https://www.malaysia-chronicle.com/wp-content/cache/autoptimize/autoptimize_04b51da1b601d1ef78596d816f104653.php" rel="stylesheet" /><link media="all" href="https://www.malaysia-chronicle.com/wp-content/cache/autoptimize/autoptimize_0553d4cc5ccf918f9dab7f1ca0be7bb6.php" rel="stylesheet" /><title>Malaysia Chronicle</title><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans"><link rel="pingback" href="https://www.malaysia-chronicle.com/xmlrpc.php"/><link rel="shortcut icon" href="https://www.malaysia-chronicle.com/wp-content/themes/mnews/images/favicon.ico" type="image/x-icon" /><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//code.jquery.com' /><link rel='dns-prefetch' href='//cdn.innity.net' /><link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; Feed" href="https://www.malaysia-chronicle.com/?feed=rss2" /><link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; Comments Feed" href="https://www.malaysia-chronicle.com/?feed=comments-rss2" /><link rel="alternate" type="application/rss+xml" title="Malaysia Chronicle &raquo; SURELY MUHYIDDIN-AZMIN COMBO CANNOT BE SO DUMB! MCO EXTENSION GOOD FOR CURBING VIRUS CONTAGION &#8211; BUT IF THEY KEEP IGNORING NON-ESSENTIAL SERVICES SECTOR &#8211; &#038; ONLY CARE ABOUT HAIRCUTS &#8211; MALAYSIANS WILL ALSO DIE A PAINFUL ECONOMIC DEATH! Comments Feed" href="https://www.malaysia-chronicle.com/?feed=rss2&#038;p=188103" /> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js'></script> <script type='text/javascript'>var ai_front = {"wp_ai":"5.2.5+2.6.3","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN","fallback":"FALLBACK","automatically_placed":"Automatically placed by AdSense Auto ads code"};</script> <script type='text/javascript'>var sfpp_script_vars = {"language":"en_US","appId":"facebook.com\/wong.c.mei.1"};</script> <script type='text/javascript' src='https://code.jquery.com/jquery-migrate-1.2.1.min.js'></script> <script type='text/javascript' src='https://cdn.innity.net/admanager.js'></script> <link rel='https://api.w.org/' href='https://www.malaysia-chronicle.com/index.php?rest_route=/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.malaysia-chronicle.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.malaysia-chronicle.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='&#8216;ALLOW THOSE WITH ANTI-BODIES AGAINST COVID-19 TO RESUME WORK&#8217; &#8211; EX-HEALTH MINISTER RAPS MUHYIDDIN &#038; CO FOR LACK OF STRATEGY &#8211; DON&#8217;T PROLONG MCO WITHOUT IDEAS FOR A WAY FORWARD, LET SELANGOR LEAD THE WAY WITH MASS TESTING FOR ANTI-BODIES' href='https://www.malaysia-chronicle.com/?p=188089' /><link rel='next' title='ANNUAR MUSA SPEAKS AGAIN WITHOUT THINKING &#8211; BUT IT&#8217;S NOT JUST THE HOMELESS BUT OTHER MALAYSIANS WHO WILL NEED JOBS DUE TO VIRUS FALLOUT!' href='https://www.malaysia-chronicle.com/?p=188092' /><meta name="generator" content="WordPress 5.2.5" /><link rel="canonical" href="https://www.malaysia-chronicle.com/?p=188103" /><link rel='shortlink' href='https://www.malaysia-chronicle.com/?p=188103' /><link rel="alternate" type="application/json+oembed" href="https://www.malaysia-chronicle.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D188103" /><link rel="alternate" type="text/xml+oembed" href="https://www.malaysia-chronicle.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D188103&#038;format=xml" /><div id="fb-root"></div> <script>(function(d, s, id) {
	  var js, fjs = d.getElementsByTagName(s)[0];
	  if (d.getElementById(id)) return;
	  js = d.createElement(s); js.id = id;
	  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=&version=v2.3";
	  fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));</script><meta name="twitter:card" 		content="summary_large_image" /><meta property="og:url"			content="https://www.malaysia-chronicle.com/?p=188103" /><meta property="og:type"			content="article" /><meta property="og:title"			content="SURELY MUHYIDDIN-AZMIN COMBO CANNOT BE SO DUMB! MCO EXTENSION GOOD FOR CURBING VIRUS CONTAGION - BUT IF THEY KEEP IGNORING NON-ESSENTIAL SERVICES SECTOR - &amp; ONLY CARE ABOUT HAIRCUTS - MALAYSIANS WILL ALSO DIE A PAINFUL ECONOMIC DEATH!" /><meta property="og:description" 	content="KUALA LUMPUR: The economic impact of the extended Movement Control Order (MCO) may be more" /><meta property="og:image" 		content="https://www.malaysia-chronicle.com/wp-content/uploads/2020/03/68cefd17aca1e3d3821ec4993f139cf7ac2f65cd-28.jpg" /><meta data-pso-pv="1.2.1" data-pso-pt="singlePost" data-pso-th="1013ecffa1a1fbf51d72e12a83fe4e89">  <script type="text/javascript" src="https://cdn.innity.net/admanager.js"></script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-2711886266814791",
          enable_page_level_ads: true
     });</script> </head><body data-rsssl=1 class="post-template-default single single-post postid-188103 single-format-standard"><div class="container"><header class="header-wrap"><div class="wrapper"><div class="logo-wrap" role="banner"><div class="logo"> <a href="https://www.malaysia-chronicle.com/" title="Malaysia Chronicle" rel="home"> </a></div><div class="ad-topline"></div></div></div><nav class="main-nav clearfix"><div class="wrapper"><div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-118487" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home current-post-parent menu-item-118487"><a href="https://www.malaysia-chronicle.com/">Home</a></li><li id="menu-item-118482" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-118482"><a href="https://www.malaysia-chronicle.com/?cat=2">Politics</a></li><li id="menu-item-118484" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-118484"><a href="https://www.malaysia-chronicle.com/?cat=3">Business</a></li><li id="menu-item-118485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118485"><a href="https://www.malaysia-chronicle.com/?cat=4">Social</a></li><li id="menu-item-121976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121976"><a href="https://www.malaysia-chronicle.com/?cat=27">Malay</a></li><li id="menu-item-118486" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-118486"><a href="https://www.malaysia-chronicle.com/?cat=7">Videos</a></li><li id="menu-item-120318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-120318"><a href="https://www.malaysia-chronicle.com/?cat=6">Latest</a></li><li id="menu-item-124988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124988"><a href="https://www.malaysia-chronicle.com/?page_id=124986">Contact</a></li></ul></div><div class="search-box"><form role="search" method="get" id="searchform" action=""><fieldset> <input name="s" id="s" value="" autocomplete="off" placeholder="SEARCH" type="text"> <input id="searchsubmit" value="" type="submit"></fieldset></form></div></div></nav>  <script type="text/javascript">new innity_adZone("e077e1a544eec4f0307cf5c3c721d944", "41786", {"origin": "MY"});</script> </header><div class="wrapper ad-leader1"><div class="sp-widget"> <script type="text/javascript" src="https://js.genieessp.com/t/166/745/a1166745.js"></script> </div></div><div class='code-block code-block-6' style='margin: 8px 0; clear: both;'><div id="jubna8534"></div> <script type="text/javascript">(function() {
var params =
{
id: "ac64e36d-03a7503c-a7383c82-3fd2f319",
d: "YWJvdWRjcm0uY29t",
cb: ((new Date()).valueOf().toString())
}; 
var qs="";
for(var key in params){qs+=key+"="+params[key]+"&"}
qs=qs.substring(0,qs.length-1);
var s = document.createElement("script");
s.type= "text/javascript";
s.setAttribute("data-cfasyn", "false");
s.src = "https://jubna.com/en/api/widget/8534?" + qs;
s.async = true;
document.getElementById("jubna8534").appendChild(s);
})();</script> </div><div class="wrapper clearfix"><div class="content left"><article class="post-188103 post type-post status-publish format-standard has-post-thumbnail hentry category-business category-politics"><header class="post-header"><h1 class="entry-title">SURELY MUHYIDDIN-AZMIN COMBO CANNOT BE SO DUMB! MCO EXTENSION GOOD FOR CURBING VIRUS CONTAGION &#8211; BUT IF THEY KEEP IGNORING NON-ESSENTIAL SERVICES SECTOR &#8211; &#038; ONLY CARE ABOUT HAIRCUTS &#8211; MALAYSIANS WILL ALSO DIE A PAINFUL ECONOMIC DEATH!</h1><p class="meta post-meta"> <a href="https://www.malaysia-chronicle.com/?cat=3" rel="category">Business</a>, <a href="https://www.malaysia-chronicle.com/?cat=2" rel="category">Politics</a> | <span class="updated">April 11, 2020</span> by <span class="vcard author"> </span> |  0 Comments</p></header><div class="entry clearfix"><div class="post-thumbnail"> <a href="https://www.malaysia-chronicle.com/wp-content/uploads/2020/03/68cefd17aca1e3d3821ec4993f139cf7ac2f65cd-28.jpg" rel="prettyPhoto"><img src="https://cdn.shortpixel.ai/client/q_lossy,ret_img/https://www.malaysia-chronicle.com/wp-content/uploads/2020/03/68cefd17aca1e3d3821ec4993f139cf7ac2f65cd-28-618x348.jpg" alt="" title="68cefd17aca1e3d3821ec4993f139cf7ac2f65cd" /></a></div><p>KUALA LUMPUR: The economic impact of the extended Movement Control Order (MCO) may be more severe to sectors classified as “non-essential services”, especially the manufacturing sector for exports.</p><div class='code-block code-block-9' style='margin: 8px 0; clear: both;'>  <script type="text/javascript" src="https://js.genieessp.com/t/427/594/a1427594.js"></script></div><p>Prime Minister Tan Sri Muhyiddin Yassin on Friday announced an extension of the MCO by another two weeks until April 28.</p><div class='code-block code-block-4' style='margin: 8px auto; text-align: center; display: block; clear: both;'>  <script type="text/javascript" src="https://js.genieessp.com/t/345/500/a1345500.js"></script></div><div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>  <script type="text/javascript" src="https://js.genieessp.com/t/166/863/a1166863.js"></script> <div id="jubna5045"></div> <script type="text/javascript">(function() {
var params =
{
id: "ac64e36d-03a7503c-a7383c82-3fd2f319",
d: "YWJvdWRjcm0uY29t",
cb: ((new Date()).valueOf().toString())
}; 
var qs="";
for(var key in params){qs+=key+"="+params[key]+"&"}
qs=qs.substring(0,qs.length-1);
var s = document.createElement("script");
s.type= "text/javascript";
s.setAttribute("data-cfasyn", "false");
s.src = "https://jubna.com/en/api/widget/5045?" + qs;
s.async = true;
document.getElementById("jubna5045").appendChild(s);
})();</script> </div><p>Muhyiddin said this was imperative to prevent the Covid-19 pandemic from escalating and infecting more people in the country.</p><p>Bank Muamalat Malaysia Bhd economist Izuan Ahmad said the government should address MCO issue by having discussions with the relevant sectors on whether to allow non-essential services to resume operations albeit within tight and strict control.</p><p>“The decision or other options are important to avoid further negative impact on the non-essential services sector,” he told the New Straits Times (NST) yesterday.</p><p>He, nevertheless, said the extension was a positive step to curb the pandemic.</p><p>He called for a smooth implementation of the RM260 billion Prihatin stimulus.</p><p>“Efficient implementation of the allocations to the respective beneficiaries is crucial to avoid further adverse impact from this extended MCO,” he said.</p><p>Putra Business School business development manager Associate Professor Dr Ahmed Razman Abdul Latiff expects businesses and organisations to encourage their workers to continue working from home especially if they have the technology and system for that purpose.</p><p>“Some businesses will improve on their logistic and supply chain to cater for the changing behaviour of their customers who probably wanted the product or services delivered to them rather than they go to the business premises,” he told the NST.</p><p>He said psychologically, people would likely behave differently after MCO, as majority of the public would still practice social distancing and wear masks.</p><p>“However, the working people and those with businesses to handle will be eager to resume their working life especially those who are getting lower pay or not getting paid at all during the MCO,” he said.</p><p>Ahmed Razman said it would probably take months to return to normalcy given that global economies were facing possible recession for the next few months.</p><p>“Domestic economic activities will be subdued and sluggish as people will still be afraid to spend and would rather save their money.</p><p>“The customer confidence level needs to be improved to kick start the business activities again,” he said.</p><p>He expects the country’s gross domestic product to ease by 2.0 per cent or about RM34 billion due to the pandemic.</p><p>This translates into a reduction in monetary value of all finished goods and services made during the first-quarter of 2020.NST</p><h1 class="page-title mb-2"><span class="d-inline-block mr-1">Certain businesses given green light to operate during MCO</span><img class="img-fluid" style="font-size: 16px;" src="https://assets.nst.com.my/images/articles/08bh13azm_1586522054.jpg" alt="(File pic) Senior Minister Datuk Seri Mohamed Azmin Ali said the government's decision was based on findings from studies. -NSTP/AHMAD IRHAM MOHD NOOR." /></h1><div class="page-article"><div class="article-content"><div><div class="field field-featured-image"><figure><figcaption class="py-2">(File pic) Senior Minister Datuk Seri Mohamed Azmin Ali said the government&#8217;s decision was based on findings from studies. -NSTP/AHMAD IRHAM MOHD NOOR.</figcaption></figure></div></div><div class="field field-body"><p>KUALA LUMPUR: Several sectors involving key areas have been given the green light to resume operations in stages under the Movement Control Order (MCO) period, which has now been extended for another two weeks until April 28.</p><p>Among the services allowed to operate are hair cut service (hair cut only), launderettes (not self-service laundromats), hardware stores, electrical and electronics stores and optical shops.</p><p>Senior Minister Datuk Seri Mohamed Azmin Ali said the government&#8217;s decision was based on findings from studies that indicate that the spread of Covid-19 would not only have a significant impact on health, but would also have detrimental effects on the economy and the well-being of the Malaysian people.</p><p><iframe src="https://www.youtube.com/embed/SX61nToXqF8" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen" data-mce-fragment="1"></iframe>This, the International Trade and Industry Minister said includes Small and Medium Enterprises (SME) which comprise the largest contributor to the nation’s workforce.</p><p>This step, he said, was also necessary to ensure the sustainability of the country’s economy post Covid-19, to prevent the loss of jobs among Malaysians and to ensure that the rakyat continues to have access to basic needs and critical products throughout the MCO period.</p><p>“Pursuant to the government&#8217;s decision to allow several critical manufacturing and services sectors to operate during the first phase of the MCO, the level of compliance by the approved companies has been satisfactory and encouraging.</p><p>“Nevertheless, the government continues to monitor the compliance of the conditions as stipulated by the Health Ministry and also to ensure that health screening and preventive measures are implemented for the safety of employees and customers.</p><p>“MITI has engaged with various stakeholders including business and industry associations, SMEs, and other relevant Ministries and agencies, including MoH and the National Security Council (NSC), to identify and review additional economic sectors that can be allowed to operate.</p><p>“This measure is in line with the Cabinet’s decision to establish a Special Cabinet Committee to Mitigate the Impact of Covid-19 on the Economy and Labour Market. The Special Cabinet Committee tabled several proposals to the Cabinet on April 6 and 8,” he said in a statement today.</p><p>Following the presentations by MITI, Finance Ministry, Khazanah Nasional Berhad and Bank Negara Malaysia, the Cabinet, he said, had decided to allow several additional economic sectors to operate in phases on condition of strict adherence to health and safety guidelines.</p><p>He said MITI has also reviewed the additional sectors that are allowed to operate based on its importance in the global value chain or GVC and the country&#8217;s exports (this step is to ensure the stability of export activities; activity of economic sectors with high value-added multiplier; impact on the sustainability of SMEs in the economic sector, particularly in manufacturing and services; and size of workforce involved).</p><p>Companies in the additional sectors listed may submit their application to MITI beginning Monday, April 13, from 9 am.</p><p>All applications must be made online via MITI&#8217;s website at <a href="http://www.miti.gov.my/">www.miti.gov.my</a>. Only applications that are complete and fulfil the set conditions will be processed.</p><p>“Companies in the sectors that are allowed to operate must comply with the requirements of the Standard Operating Procedure (SOP).</p><p>“In addition to adhering to these enhanced terms and guidelines, operating permits are also subject to compliance with the requirements set by the Health Ministry and guidelines by other relevant enforcement agencies from time to time. Failure to comply will result in the immediate revocation of the operating permit and legal action,” Azmin said.</p><p><span style="color: #ff0000;"><strong>Other services allowed to operate are social health services including registered traditional medicine practitioners, science, professional and technical services including research and development (R&amp;D) (limited to: legal services; oil and gas; Covid-19 related, and testing laboratories).</strong></span></p><p>Others allowed to operate include those in the automotive Industry (limited to export of fully pre-installed units &#8211; CBUs, equipment and components, as well as after-sales services for example maintenance), machinery and equipment industry, aerospace Industry, and construction projects and construction related services.</p><p>Some are however subject to limitations. &#8211; NST</p><p>NST</p><div class='code-block code-block-3' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>  <script type="text/javascript" src="https://js.genieessp.com/t/324/437/a1324437.js"></script></div></div></div></div><p>.</p><div class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'><div id="jubna3035"></div> <script type="text/javascript">(function() {
var params =
{
id: "ac64e36d-03a7503c-a7383c82-3fd2f319",
d: "YWJvdWRjcm0uY29t",
cb: ((new Date()).valueOf().toString())
}; 
var qs="";
for(var key in params){qs+=key+"="+params[key]+"&"}
qs=qs.substring(0,qs.length-1);
var s = document.createElement("script");
s.type= "text/javascript";
s.setAttribute("data-cfasyn", "false");
s.src = "https://jubna.com/en/api/widget/3035?" + qs;
s.async = true;
document.getElementById("jubna3035").appendChild(s);
})();</script> <div id="MarketGidScriptRootC43439"><div id="MarketGidPreloadC43439"> <a id="mg_add43439" href="http://mgid.com/advertisers/?utm_source=widget&utm_medium=text&utm_campaign=add" target="_blank">Place your ad here </a> <br> <a href="http://mgid.com/" target="_blank">Loading... </a></div> <script>(function(){ var D=new Date(),d=document,b='body',ce='createElement',ac='appendChild',st='style',ds='display',n='none',gi='getElementById'; var i=d[ce]('iframe');i[st][ds]=n;d[gi]("MarketGidScriptRootC43439")[ac](i);try{var iw=i.contentWindow.document;iw.open();iw.writeln("<ht"+"ml><bo"+"dy></bo"+"dy></ht"+"ml>");iw.close();var c=iw[b];} catch(e){var iw=d;var c=d[gi]("MarketGidScriptRootC43439");}var dv=iw[ce]('div');dv.id="MG_ID";dv[st][ds]=n;dv.innerHTML=43439;c[ac](dv); var s=iw[ce]('script');s.async='async';s.defer='defer';s.charset='utf-8';s.src="//jsc.mgid.com/m/a/malaysia-chronicle.com.43439.js?t="+D.getYear()+D.getMonth()+D.getDate()+D.getHours();c[ac](s);})();</script> </div></div><div id="dpsp-content-bottom" class="dpsp-content-wrapper dpsp-shape-rectangular dpsp-column-auto dpsp-show-on-mobile dpsp-button-style-1 dpsp-has-icon-background dpsp-has-button-background"><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-content "><li><a rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D188103&#038;t=SURELY%20MUHYIDDIN-AZMIN%20COMBO%20CANNOT%20BE%20SO%20DUMB%21%20MCO%20EXTENSION%20GOOD%20FOR%20CURBING%20VIRUS%20CONTAGION%20-%20BUT%20IF%20THEY%20KEEP%20IGNORING%20NON-ESSENTIAL%20SERVICES%20SECTOR%20-%20%26%20ONLY%20CARE%20ABOUT%20HAIRCUTS%20-%20MALAYSIANS%20WILL%20ALSO%20DIE%20A%20PAINFUL%20ECONOMIC%20DEATH%21" class="dpsp-network-btn dpsp-facebook dpsp-first"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Facebook</span></span></a></li><li><a rel="nofollow" href="https://twitter.com/intent/tweet?text=SURELY%20MUHYIDDIN-AZMIN%20COMBO%20CANNOT%20BE%20SO%20DUMB%21%20MCO%20EXTENSION%20GOOD%20FOR%20CURBING%20VIRUS%20CONTAGION%20-%20BUT%20IF%20THEY%20KEEP%20IGNORING%20NON-ESSENTIAL%20SERVICES%20SECTOR%20-%20%26%20ONLY%20CARE%20ABOUT%20HAIRCUTS%20-%20MALAYSIANS%20WILL%20ALSO%20DIE%20A%20PAINFUL%20ECONOMIC%20DEATH%21&#038;url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D188103" class="dpsp-network-btn dpsp-twitter"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">Twitter</span></span></a></li><li><a rel="nofollow" href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.malaysia-chronicle.com%2F%3Fp%3D188103&#038;title=SURELY%20MUHYIDDIN-AZMIN%20COMBO%20CANNOT%20BE%20SO%20DUMB%21%20MCO%20EXTENSION%20GOOD%20FOR%20CURBING%20VIRUS%20CONTAGION%20-%20BUT%20IF%20THEY%20KEEP%20IGNORING%20NON-ESSENTIAL%20SERVICES%20SECTOR%20-%20%26%20ONLY%20CARE%20ABOUT%20HAIRCUTS%20-%20MALAYSIANS%20WILL%20ALSO%20DIE%20A%20PAINFUL%20ECONOMIC%20DEATH%21&#038;mini=true" class="dpsp-network-btn dpsp-linkedin dpsp-last"><span class="dpsp-network-icon"></span><span class="dpsp-network-label-wrapper"><span class="dpsp-network-label">LinkedIn</span></span></a></li></ul></div><div class="fb-comments" data-href="https://www.malaysia-chronicle.com/?p=188103" data-width="100%" data-numposts="5" data-colorscheme="light" data-numposts="5" data-order-by="social"></div></div></article><nav class="section-title clearfix" role="navigation"><div class="post-nav left"> <a href="https://www.malaysia-chronicle.com/?p=188089" rel="prev">&larr; Previous article</a></div><div class="post-nav right"> <a href="https://www.malaysia-chronicle.com/?p=188092" rel="next">Next article &rarr;</a></div></nav></div><aside class="sidebar sb-right"><div class="sp-widget"> <script type="text/javascript" src="https://js.genieessp.com/t/225/640/a1225640.js"></script> </div><div class="sb-widget"><h4 class="widget-title">LATEST</h4><ul><li> <a href="https://www.malaysia-chronicle.com/?p=188179">MAHATHIR CAMP ATTACKS &#8216;CUNNING&#8217; MUHYIDDIN: HE IS SHREWDLY MILKING THE COVID-19 &#038; LEADING MALAYSIA BACK INTO UMNO ERA &#8211; &#8216;BY NOT APPOINTING A DPM, HE IS MAKING HIMSELF INDISPENSABLE&#8217; AND ENDANGERING MALAYSIA &#8211; FOR HOW LONG CAN THE FRAGILE APPLE CART STAY UPRIGHT BEFORE THE 4 SENIOR MINISTERS FIGHT HIM &#038; EACH OTHER FOR THE TOP POST?</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=188185">RAFIDAH POURS &#8216;ACID&#8217; ON MUHYIDDIN REGIME &#038; HITS BULLSEYE &#8211; &#8216;SOME PEOPLE RUNNING THE COUNTRY NEED TO GO BACK TO BASICS ON HOW TO GOVERN&#8217;: UNDER THE GUISE OF COVID-19, COUP GOVT GRABBING ALL THE GOVT POSTS TO REWARD CRONIES &#038; POLITICAL ALLIES &#8211; &#8216;IRON LADY&#8217; MINCES NO WORDS</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=188181">IN SARAWAK, THE PLUNDER INTENSIFIES: EVEN THE COVID-19 DISASTER FUND IS NOT SPARED &#8211; AS ELITE POLITICIANS &#038; THEIR CRONIES RUSH FOR THE &#8216;LAST GRAB&#8217;</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=188175">BOMBSHELL &#8211; WHAT TYPE OF COVID-19 LURKS IN MALAYSIA &#8211; TYPE  &#8216;A&#8217;, &#8216;B&#8217; OR &#8216;C&#8217;: SHOCKED AT SPEED OF SPREAD, SCIENTISTS DISCOVER 3 VARIANTS &#8211; BOLSTERING TALK IT WAS AMERICA THAT FIRST SPREAD THE CORONAVIRUS BUT IT BACKFIRED!</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=188115">BOMBSHELL &#8211; &#8216;MCO&#8217; OF THE LONG KNIVES FOR MUHYIDDIN: FINALLY BACKDOOR PM ADMITS HIS COUP GOVT IS NOW DESPERATE &#038; FEARFUL THE ECONOMY WILL TANK OUT OF CONTROL &#8211; SAD TO SAY, HIS &#8216;TRUSTED&#8217; CLOWN MINISTERS INCLUDING OR ESPECIALLY AZMIN MAY ONLY BE WAITING TO SEE WHEN IS THE BEST TIME TO OUST &#038; DUMP HIM</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=188121">71 CABINET MINISTERS &#8211; AND ALL OF THEM MAKING STUPID STATEMENTS: BY NOW IT IS CLEAR &#8211; MUHYIDDIN&#8217;S MCO IS ACTUALLY THE &#8216;FINAL HONEYMOON&#8217; FOR RACIAL SUPREMACY &#8211; ONCE DONE, A HEADLONG PLUNGE INTO ECONOMIC RUINS AWAITS</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=188125">&#8216;COCKEYED&#8217; AZMIN CAN&#8217;T WAIT TO GET A HAIRCUT, IS IT? MUHYIDDIN &#038; CO GRILLED OVER JOKE OF AN &#8216;EXIT STRATEGY&#8217; FOR COVID-19 &#8211; &#8216;IS THIS BECAUSE SOME MINISTERS WANT TO VISIT A BARBERSHOP OF HAIR SALON?&#8217; ASKS KIT SIANG &#8211; EVEN AS ECONOMIC FALLOUT STARTS TO BITE WITH A VENGEANCE</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=188154">&#8216;CASANOVA&#8217; SYED SADDIQ? WALAU TAK DISEBUT NAMANYA, SYED SADDIQ WAJIB TAMPIL JAWAB DAKWAAN</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=188139">A WEDDING TO REMEMBER &#8211; EVEN IN COVID-19 TRAGEDY, MUHYIDDIN REGIME &#038; MALAYSIA&#8217;S &#8216;DEEP STATE&#8217; STILL PLAYING RACIAL &#038; RELIGIOUS HATE GAMES?</a></li><li> <a href="https://www.malaysia-chronicle.com/?p=188149">BOMBSHELL OF SHAME &#8211; M&#8217;SIAN POLICE INSPECTOR RAPES 2 MONGOLIAN WOMEN AFTER STOPPING THEM AT COVID-19 ROADBLOCK:  WHAT SAYS IGP? INSTEAD OF RELENTLESSLY BARKING AT MAN-ON-THE-STREET MCO VIOLATORS &#8211; HE SHOULD GET HIS OWN HOUSE IN ORDER FIRST!</a></li></ul></div><div class="sp-widget"> <script type="text/javascript" src="https://js.genieessp.com/t/167/412/a1167412.js"></script> </div></aside></div></div>  <script type="text/javascript" src="https://js.genieessp.com/t/088/371/a1088371.js"></script> <div class="copyright-wrap"><p class="copyright">Copyright &copy; 2020 | Malaysia Chronicle</p>   <script type="text/javascript" src="https://js.genieessp.com/t/143/930/a1143930.js"></script> <script defer src="https://www.malaysia-chronicle.com/wp-content/cache/autoptimize/autoptimize_7d19b8dd1a01d4e47ab9323f57a0fae4.php"></script><!--noptimize--><!-- Autoptimize found a problem with the HTML in your Theme, tag `/body` missing --><!--/noptimize-->